Composers names don't fit

There’s a list of composers for the current project, and they don’t fit the frame under {@projectComposer@} as is. I have spent three years doing anything I can to avoid learning how to edit the token parameters on the Page Layouts. LOL! What is the most current video or easiest way to finally learn?

Rather than changing the token parameters (which I do not think is possible), I would try expanding the composer field in your Page Templates (assuming you are using Pro). Dragging the left side of the box further left should help, and since the box aligns text to the right, adding too much space will not display incorrectly.

One could also drag the bottom of the Composer text box downward (and change the text alignment to Top), but one might have to be careful where the line break occurs or borrow another File Info token and assign it to Composer Text and a second line in the Composer box.

thanks for answer. I have already been fooling with this and doesn’t help yet. Is this the right area at least? (I have Pro)

Here is a sample showing what happens to long composer credits if I…

  1. Stretch the field to the left
  2. Divide the composers between two fields one over the other *
  3. Leave the current options in place
  • to put all options in one file, I had to use Copyist and Artist fields for the divided composer setup.
    composerField Option.dorico (502.0 KB)

In your example you would want to use Properties to align your Composer (and Lyricist) text fields to the Top. By default they are centered vertically.

A old one but in the beginning around min 9 he’s fiddling around with header and token, etc

Make sure you copy these changes to the other side (looks like L > R in your case?) As Dorico only uses the left side of page templates on even pages, and the right side on odd pages.


thanks Derrek. How do I get to text alignment in Properties?

Click on the edge of the frame to select it (make sure you have the frame tool selected in the left panel), and open the bottom Properties panel.

Ok I’m getting there! I am all set in the condensed score. However it is not replicated to parts. It’s a big score, do I need to adjust each player’s part separately? Thanks for working with me on this!

No, you just need to edit the Parts page template set (you’ve already edited the Score page template set). The parts page template set affects all part layouts by default (unless you re-assign them).