Computer doesn't recognize ur44

Just bought ur44, I have a Windows 8 pc. I installed all the softwares from the cd (Yamaha Steinberg USB Driver, Steinberg UR44 Applications and Basic FX Suite), following both the intallation software and all the passages written in the Getting Started guide. The softwares have been installed correctly, I connected the ur44 to the computer following the indications in the guide, but when I turn it on the power led starts blinking and doesn’t stop, and my computer doesn’t find the device in Control Panel. I also tried to uninstall and re-install the softwares and to upgrade them through the download on, but the problem is still the same, what else could be wrong?

I have the same problem With Windows 8.1. The driver for UR44 fails after installing and UR44 can’t be reconized. No errors Messages but a warning i Device manager. I’m quite near using a hammer on the sound card to see if that works…

I’ve a similar problem. UR44 is now recognised, but when I try to download ai, it tells me that UR44 “serial number is not valid”
Can anyone help please??? :confused:

Having similar problem eLCC (eLicensing center program not displaying UR440) I have installed the UR44 per instruction and it shows up under Device Manager on computer, but when go to activate the the software license in eLCC the UR44 is not listed on the Left colum labeled “elicensers”, “My Licenses”. Because of this I cant activate and use the software. Anyone know anything about this please? :confused:

We are also having this problem… :frowning:

Same, divers installed but being told it drivers cant be found.

Did anybody find a solution to this problem? I’m having the exact same issue. Device Manager shows yellow exclamation mark, and updating driver does nothing. “Driver not found” message in Control Panel.

Admin, are you replying to this thread? Thank you.

Has anybody solved this problem? Would love to know the solution. I’m getting a yellow exclamation mark in windows device manager and a ‘no valid driver’ notification ‘devices’. The driver is installed and I reinstalled, but UR44 still isn’t functioning. Please help, moderators.