Computer keyboard shortcuts stop working when Right Zone Media Bay is open

This issue has started after I installed update 10.0.40. I’m using Cubase Pro on a Windows 10 computer.

Anytime I have the Right Zone open on the Media Bay, I can not use any keyboard shortcuts. I get this error: “The On-Screen Keyboard filtered this Key Command” (see attached image). The On-Screen Keyboard is not open as you can see in the screenshot. I have to close the Right Zone for keyboard shortcuts to start working again. I use a lot of samples in my work, I need to be able to use keyboard shortcuts while the Right Zone is open. Having that zone open shouldn’t stop the use of keyboard shortcuts, how can we fix this problem?




Hi,

The on-screen keyboard has to be somewhere, when the message (not error message) says it. The message is triggered together with the on-screen keyboard.

It’s not anywhere because when I go to the menu Studio and select On-Screen Keyboard, it opens up the On-Screen Keyboard. Even after opening the On-Screen Keyboard and closing the On-Screen Keyboard, I still get that error message when I try to use a keyboard shortcut while the Right Zone Media Bay is open. Is there another option to enable/disable it? I can’t find one in Preferences.

Here’s a screenshot of what the On-Screen Keyboard looks like when it’s open:

The on-screen keyboard has to be closed . When it’s open it blocks Key Commands to make it possible to play music using the alpha keyboard. If you get the message that you posted in original post above, that means it’s open.

Like I stated, the On-Screen keyboard is closed and it still gives me “The On-Screen Keyboard filtered this Key Command” whenever I try to use a keyboard shortcut while the Right Zone Media Bay is open. I can open the On-Screen Keyboard by going up the the Studio menu and selecting On-Screen Keyboard, then close the On-Screen Keyboard and I still get the “The On-Screen Keyboard filtered this Key Command” whenever I try to use a keyboard shortcut while the Right Zone Media Bay tab is open. If I close the Right Zone Media Tab, then I can use keyboard shortcuts again. While doing this, the On-Screen keyboard is not open or showing anywhere on the screen.

I never had this problem with 9.5, 10.0.0, 10.0.10, 10.0.20 or 10.0.30. It just started happening after I updated to 10.0.40.

You had two threads going on the same topic. I merged them and deleted the extraneous posts.

The merged post above is the only other solution.

Here is a video of what is happening: https://youtu.be/wpR6muAI82A

In this video, I start Cubase and I push the “F” key to toggle “Auto-Scroll” on and off, which it shows working correctly. After that, I open up the “Right Zone” to the “Media” tab and I starting pushing the “F” key on the keyboard and I get the “The On-Screen Keyboard filtered this Key Command.” When I close the “Right Zone,” keyboard shortcuts start working again. The “On-Screen Keyboard” is not turned on as you can see. I turn it on later to show how it appears when it is turned on.

Is there a setting that is automatically starting the “On-Screen Keyboard” when Cubase starts but doesn’t show it? Is there a way to permanently disable this? I can’t find any settings that relate to the “On-Screen Keyboard” in the Preferences.

I don’t have that option on the Media tab in the Right Zone, here is what mine looks like:

Navigate to a VST plugin preset folder so you can see the state of the button, how is it?

I forgot to mention, it doesn’t do this on any other tab (VSTi, CR or Meter), only when I have the Media tab open.

Hi,

I had a look to your video.

Around time 0:40 the focus is in the Right-Zone (you can see the yellow frame there) and you call a function for the Project area (Auto Scroll). Therefore it doesn’t work.

It doesn’t matter what area is selected in the project window, when the Right Zone Media tab is open, it’s not allowing the use of ANY keybaord shortcuts.

Hi,

Because the Key Command are “eaten” by MediaBay (Rack). What about Spacebar to Start/Stop project? This should work.

I don’t think so. I think On Screen Keyboard is active as a result of it having been being activated in the Right Zone. You can even see the yellow notification in there, though you can’t read it due to the low res of the video. :wink:

The Follow keystroke works without regard to which zone or window is active, just like the Transport commands.

Hi,

I have just tried here on my side and it works to me.

Here’s the repro to show what’s happening. Is this not what you are seeing, Martin?

  • Open Right zone to the Media tab and navigate to Presets>Track Presets>MIDI, select a preset.
  • Activate Computer Keyboard Input
  • Navigate back to Home by clicking on the Home icon
  • Press F on the computer keyboard

command is not passed, message is posted “The On-Screen Keyboard filtered this Key Command”
at this point I could even activate other zones, with the same result, keystrokes are filtered.

As long as the Media tab is active, commands are filtered and not passed, even though the keyboard is not displayed. Then, if you navigate back to Presets>Track Presets>MIDI, you can see that Computer Keyboard Input is still active.

Hi,

This one, I can reproduce it. On the screenshot and on the video, I saw just the Audio files.

So the bug is, the virtual keyboard is not released.

Reported to Steinberg CAN-25623.

correct. The OP’s video was not accurate.