Condensed staves issues w/Label stacking and unwanted rests

Hey Everyone,

I’m now in my second month of working with Dorico. I’m using version 5. I could use some guidance here with two areas that involve condensed staves.

When I condense my staves, I’m getting a stacked instrument list that I would like to view horizontally. I have tried to set this in Engrave mode but nothing seems to change. example:
Screenshot Stacked Labels

The other issue is also with condensed staves. I do not see a need to include rests (In many cases) for instruments who aren’t playing within the condensed stave. Things get very cluttered. I also included an example. I would like to hide these rests without having to alter color ( to full white) to hide. IS there a simple work around?

I am wondering whether you have modified the instruments names. For instance, if you edit the clarinet 1 name, only “Clarinet” should appear. Dorico will append the necessary numbers, and will be able to use “Clarinet” once for both instruments. Butvif you’ve manually added the numbers, the names are no longer the same, which makes it impossible for Dorico to show them as expected.
As for the rests in condensed staves, there are Notation options not to display them (cmd-shift-N).

Beautiful! Fixed! Thanks Marc!

Ok Marc, I spoke a tad too soon. I went ahead and removed the (1) after the instrument names. Like Oboe 1 to just Oboe. Dorico then reset things and the condensed score stave looked correct! Yay! However, I did the same all the way down the score, then noticed that some instruments ( Clarinets and Horns) would not show correctly. It would just show as Clarinet instead of Clarinet 1+2 . What’s happening here?

There are different Engraving options (Staff labels, I find strange to have Roman numerals on solo players, it might be personal, I don’t know), you should really explore them. There are also Engraving options>Condensing.
There are many options in Layout options> Staves and Systems that are worth exploring (for instance the way the transposition is shown). For instance, you can have them on a second line (which is quite convenient in French…)

In good time, however, none of these have fixed the current problem . Very odd to have my flutes and oboes set up exactly the same way as the clarinets and the clarinets not showing as clarinet I,II or 1+2

They are not set up “exactly the same way”: If you look closely, the instruments held by your two Oboe players are named “Oboe I” and “Oboe II”, whily the instruments held by your Clarinet players are both named only “Clarinet (B Flat)” without any number.

1 Like

I suspect one of the clarinets has a “space bar” included in the name, which makes them different for Dorico… but I agree, appended numbers is the rule, I don’t see why anyone would get rid of it.

The cleanest way to get instrument names back to their original state (meaning they match for all instances of that instrument in the project) is to reset them, to make sure you’ve not left any hanging spaces or carriage returns in individual instrument names.

1 Like

Thanks for you help and attention to this matter. I have tried both directions here and still getting same result. First, here is the example of what happens if I add the player number to mirror oboes and flutes:

Items remain stacked vertically. Ok, moving on…

In this scenario, I have done as Lillie suggested and reset the player defaults. It is now back to listing just a single Clarinet. Not sure why?


The fact the instrument labels in the Players panel aren’t showing instrument numbers suggests something odd is going on with the Clarinets.

If you share the project, or a duplicate version of it that contains just the clarinet players and a few bars of music, someone can take a look.

1 Like

Ok Lillie,

Whats the best way for me to share this file to you? This is my first time sending a file.

If you’ve cut it down, you can just add it to a comment here in this thread.

You’re also welcome to message me privately here on the forum and send it just to me (not publicly) that way – click my profile picture, and in the pop-up that appears, click “Message”.

Wondering World .dorico (1.7 MB)

Here ya go!

Your Clarinet instrument names weren’t reset to default, as described in link provided above. Make sure you’re following the instructions for resetting instrument names, not player names.

If you definitely did that already, it’s possible that you’ve updated your own local defaults for instrument names, so that’s why resetting at your end didn’t work.

Ditto for your French Horns and Trombones. It also looks like your first French Horn isn’t a proper “french horn”– you can use the “change instrument” function to reselect the correct French Horn instrument without needing to rewrite their parts.

On a side note:

  • If you want to edit the appearance of things like titles and composer text, edit the underlying page template and paragraph styles for a more consistent result (that you also don’t need to replicate manually on the first page in every layout)

  • “Legato” exists as a playing technique, saving you entering is as staff-attached text.

1 Like


I did as you suggested with resetting instrument names. I went to setup then clicked change to default. Am I getting this wrong? I do not have any other stored settings in my program since I only started working in Dorico last month.
Screenshot 2023-11-07 at 9.54.22 AM
Screenshot 2023-11-07 at 9.54.31 AM

Try Changing the Instrument to a Clarinet in the transposition you want.

Tried…No change.


Update. My work around, created new blank parts, copied and pasted all midi data from old staves to new staves. That sis the job. Not the solution I had hoped, but got er done. Does this problem have anything to do with files being transferred from ones DAW? If so, that’s very disappointing.

1 Like

When you import MIDI files, Dorico will rename created instruments according to the track names from the original MIDI file, to help you correlate the instruments to the tracks as you work on your orchestration. I’ve had a quick look at the options we expose when importing MIDI, and unless I’m misremembering, I don’t think you can disable that at import time. However, you can choose Setup > Reset Instrument Names after importing MIDI to reset the names of all instruments in the project to default. That should take care of any issues that arise from instruments having edited names.