Condensing changes note grouping


In this example, the condensing changes the note grouping from halfnote to tied quarters. How can I prevent this from happening?

note grouping condense.gif

The things that I’d be trying are:

  1. If there isn’t force Duration on the original staves, Force it
  2. Check Notation Options > Note Grouping

The notation options do not help, but forcing the duration does. Thanks, I still did not try that. But have a look at the minimal example here without forced durations - the first bar changes grouping, the second does not. That’s strange. (642 KB)

What’s going on here is that the syncopation detector, which is what determines whether those notes should appear as a half note or as two tied quarters, doesn’t “see” the same music on the condensed staff as on the non-condensed staves because the rests are not in the same voice as the notes. This is all a bit technical, and ideally you as the user would never have to know about it. This is something we’re already aware of and are hoping to come up with a solution for. Certainly using Force Duration to achieve the right result will be harmless in the meantime.

Similar question here. I just want the quarter note, rather than the two-eighths-tied, just like the lower staves.
I’ve tried forced duration to resolve, but it didn’t work. Any suggestions?
Different staves different treatment.png

There is a “gotcha” here, because as far as Dorico is concerned you already have a single quarter note, which is displayed as two tied 8ths because that’s how the Engraving Options say it should be displayed. If you force its duration, you just “lock” the notation of how the note is already displayed, and nothing changes. (It’s entirely reasonable to want to lock the display as two tied 8th notes, though that isn’t what you want to do!)

The trick is to select the note, change its duration, then change it back again. For example select it and press letter O for force duration, then 5 6 to change it to a single 8th and back to a quarter.

Thanks, Rob. I’ll try that!