Condensing - Lots of Bugs and Oddities

Hello, all.

After a long haitus from Dorico for various reasons, I’m getting back into it and upgraded to Dorico 3. The condensing feature was a huge draw, as I had previously been using multiple scores (one with the parts for engraving and playback and one “conductor score” where I manually condensed).

I’ve saved my file to the new version and removed all of my manually condensed staves. All I [should] have left are the parts. However, I’m seeing several weird behaviors:

  1. Placeholder rests in players which are not playing: If there is a “1.” for the first clarinet, I don’t want (or expect) to see rests for the 2nd player. It is handled correctly in Bar 5, but the rests appear in the Bassoon in Bar 11 and in both instruments in Bar 20. It seems to be related to whether the other play has any notes on that page, but I don’t want to see the rests (unless this is the gold standard for notating multiple players?)

  2. Instrument changes: I have two players: Oboe 1 and Oboe 2 + English Horn. The 2nd oboe starts with the English Horn in Bar 10. However, the staves are split until that point and then remain split even after the player changes to the Oboe. I would expect them to be condensed immediately once the second player moves to Oboe (it does seem to correct on the subsequent page and thereafter). In other flows, the Oboe 2 part becomes the English Horn part but doesn’t go back.

  3. A lot of duplicated hairpins, dynamics, and articulation (look at bar 24, for instance).

  4. A lot of clashes and collisions. I have, as I said, done a full factory reset and re-spaced all music. However, I’m seeing lots of collisions between articulations and adjacent staves (look at Bar 24, flute hairpin vs oboe slur).

(And in unrelated questions: why on Earth is my file so slow? It literally takes 30 seconds to change the top/bottom margin of a frame, even if it’s just text).


1, Is a Notation Option (or combination thereof).

  1. Is not available yet: condensing has trouble with players holding multiple instruments, but the Team is working on this.

  2. IIRC there is a setting in Engraving that allows for amalgamation of dynamics. I haven’t tried this yet.

  3. Yes, I see this too on crowded scores.

  1. Dynamics will only amalgamate if they really are identical. If Oboe 1 has f< and Oboe 2 has < then Dorico can’t amalgamate these dynamics.

If you’re finding that you’re seeing lots of collisions between items on adjacent staves, you need to give Dorico more room. You can do that by changing the page size and/or the staff size, and (perhaps counter-intuitively) by reducing the values on the Vertical Spacing page of Layout Options. You may be forcing Dorico to create too much space elsewhere, thus forcing it into positioning staves closer together than is ideal. If you can’t figure this out on your own, please attach the actual project rather than a couple of pictures, and I’ll be able to advise more constructively. There’s only so much that can be guessed from a picture that doesn’t even give sufficient context to see the entire height of the system.

If you haven’t already done so, I would recommend you have a read of the documentation for condensing changes in the Dorico 3 Version History PDF (indeed, the documentation on condensing in general in that PDF should be pretty helpful) as it will hopefully give you some hints about how to use condensing changes to start new phrases where you want Dorico to be able to change the condensation, e.g. to change between using a single voice and using two voices, etc.

The March Discover Dorico YouTube went into quite a bit of detail about vertical spacing.
https://www.youtube.com/watch?v=oGOhUlY-0Vc

Thanks, I’ll check this out!

Thanks for the input, I will definitely check out the documentation and version history! I couldn’t figure out a way to attach the file…do I need to export as a different format? In the meantime, here’s a Google Drive link: https://drive.google.com/file/d/1k89WNqYlCK35aa1W8KiWsmO6OM2F-fno/view?usp=sharing

  1. I’ve looked all through the Notation Options, but I’ll keep playing around with it. Why would it be inconsistent if it’s in the global settings, though?
  2. Thanks, I’ll look through what Daniel mentioned and see if I can force it in the meantime.
  3. I’ll check this out and ensure that the dynamics and articulations are truly identical in the condensed players. Do they need to be grouped as well?
  4. OK, guess there’s more manual handling to do than I had hoped.

Dear ANITIX87,
You can attach files here as long as they are not big (<2MB), and they end with .zip
You can change the suffix of you dorico file to .zip (instead of .dorico) and if the file is still too large, you can set the playback template to Silence in Play mode, then save and attach.

Dynamics do not need to be grouped to be condensed. But they need to be identical. My advice : select them and copy them to the staff above/below. You can create shortcuts for these copying steps. I chose alt-shift-n/m (because n/m already are used to move to staff up/down in grand instrument, and alt-n/m are used to move to staff above/below in any case. To me it makes sense.)
Hope this helps!

Thanks! Two more small oddities:

  1. What about a scenario where I have Cl.1 begin a line forte and later, Cl.2 joins in (also forte) and they crescendo together? I would expect to see “1.” with the beginning of the first line and then condensed voices on one stem when the second one comes in with a crescendo to forte. Instead, I get the “1.” with rests for the second voice, a new, redundant forte marking, and two crescendos. See the screenshots below.
  2. Bassoon passage in the second image. First Bsn plays piano, then the second comes in to reinforce and they both have a forte marking in unison. However, I’m still getting those annoying rests during the Bsn.1 passage and then split stems.

    Setting playback template to SIlent didn’t change anything in terms of filesize: still 2.7MB.

It’s in Notation Options > Condensing:

Thanks. I had upgraded to Dorico 3.10 yesterday before posting my question but this option wasn’t available. I did a system re-start after seeing your post and now I have those options (and many more). I’ll see what the behavior looks like throughout the piece.

I’ve solved the vast majority of the default formatting bugs. I also went through and made sure dynamics and articulations were grouped, that all my old text items (“1.”, “a2”, etc) were removed from when I made my own condensed score previously. I have a list of many “issues” I’m seeing (I call them issues because some may very well be my fault, or could be standard engraving practice that I don’t know about).

UPDATE: I PLAYED WITH THE “CONDENSING CHANGE” FEATURE. It solved a few of the problems, created new ones, and just outright didn’t work in most. Updated the table linked above.

Here is an updated Dorico file (too large to attach): https://drive.google.com/file/d/1bZ2ciZXsCUGakIGnGTiWUsp2mXLuCvJJ/view?usp=sharing

Here is a link to my list of issues: https://docs.google.com/spreadsheets/d/118et-QyEBYdvGNGiT2nT7BWxzLTuNtXYQioCadp-HZI/edit?usp=sharing

Here are some screenshots of my list if it’s easier to view this way:




Looking forward to any input, feedback, or advice.

Thanks!

Mvt 1:
b. 23: no idea
b. 30-34: in both cases the slurs are actually different lengths - if they’re not identical Dorico can’t amalgamate them. Dorico can only make one condensing choice per phrase (where a phrase is defined as whatever happens between rests), so because it has to use two slurs in the Flutes in 30-31 it has to also use two slurs in 32-34. Can be fixed by a condensing change at 32 that allows Flute (all) slurs to amalgamate.
b. 45-47 as immediately above.
b. 112-13 same as above.
Add a condensing change at bar 174. Dorico can’t show semibreves/whole notes (e.g. in 173) with upstem/downstem, meaning it can’t properly condense that phrase and so gives you two slurs.
b. 245 2nd bassoon slur seems to be grouped (or is that linked? I never remember) to Clarinet slurs. Remove existing bassoon slurs and replace. Ensure that both bassoons have an ff at the same location. Then add a condensing change at start of 245 that allow bassoons unlimited pitch crossing (I can’t explain why this works, but it’s come up before, in other projects).

I need to head to bed but hopefully that gives you a few pointers.

Slurs are linked. Dynamics can be linked or grouped.

Thanks for all the suggestions. I few lingering questions on these (and obviously the rest of the piece, though I can use some of these guidelines to try and address some).

  • there are SO many of these (many caused by the condensing changes). Am I going to end up having to force-hide them? (Is that even possible?)

I’m seeing this “ensure they have the same dynamics in the same place” be a factor for me. I have Bsn1 playing ‘ff’ and then Bsn2 comes in to double, also ‘ff’. Not an issue for the score, but I want to avoid the redundant ‘ff’ in the Bsn1 part. Is this a case of “do what works in the score and hide it in the part”?

Yep. Use the “Hide intensity marking” property in the part.

Hi

My guess is that many of these (extra 1) are a result of allowing amalgamation of notes and chords in notation options. With amalgamation allowed, in a phrase (or what Dorico uses as a phrase in the condensing process) you can have two or more notes sharing a steam but when the voices go rythmically apart (in the same phrase) every voice has its own steam and Dorico makes clear wich player plays what.
Since you have already made (many?) condensing changes, i’m not sure if changing the notations options at this point would be of help or could bring new unexpected changes for you.
And of course you may have good reasons to allow amalgamation. So see this post just as an attemp to understand a little bit of the condensing process.

Regards
Rafael

Yeah, I have a ton of Condensing Changes in the part, but I’ve kept track of where they all are in case I ever want to re-set the layout.

I would have thought that Dorico only assumes phrasing based on slurs and rests. The mid-voice 1. and 2. are so annoying. Is there a way to hide them?

What notation changes would you consider changing?

Unless you are making notes on what they were for, switching on the signposts for condensing changes will track where they all are automatically.

AFAIK Dorico basically considers that “condensing phrases” are subdivided by rests, except for a few situation where that doesn’t make sense like a slur or a beam over a rest, or a rest in the middle of a tuplet. (Fairly obviously, you can’t change the style of condensing in the middle of a beam or a slur!)

That highlight explains why I can’t get rid of all the extra 1. and 2. callouts (or, when it does, the slur goes away). What are my options for removing them, shy of drawing white squares over all of them (especially since it affects vertical spacing)?

You can select them in Engrave mode and in the properties panel, use Hide.