Condensing notation options unresponsive

As you can see in the attached photo, Condesning does exactly the opposite of what it’s asked to do in the Notation Options. The two flutes in unison are notated with double stems rather than a2, and also the slurs are replicated, although (further below in the options) I ask for the amalgamation of slurs. Any ideas why?
Many thanks,
(PS. The notation options are set for the correct flow, in fact I have set them globally for all flows, but it makes no difference.)

The answer is almost definitely that something off the right end of your screenshot is preventing Dorico from using that condensing approach.
As is always the case with condensed passages, we need to see right the way up until the next rest in both Flutes. Dorico can only make one condensing choice per phrase, where a phrase is defined as the notes between rests. The way to force Dorico to start a new phrase (and thus the opportunity for a different condensing approach) is to insert a Condensing Change (even one that doesn’t have any switches flicked).

Thanks pianoleo. Line 1 and Line 2 below.

Try inserting a Condensing Change on the downbeat of bar 8. You’ll need to tick the Flute 1, Flute 2 box on the left hand side but you shouldn’t need to do anything else.

Yes, that works! Thank you. But it’s not be practical to do this manually everywehre for a huge project. I presume there is no option to tell Dorico to put a ‘condensing change’ automatically after every bar? If not, perhaps one could introduce it?

There certainly isn’t a way to automatically add Condensing Changes after every bar, but I’d caution against it anyway. For what it’s worth, I’ve assigned a keyboard shortcut to the Condensing Change dialog for expediency.