Condensing problems, when it shouldn't and when it should

Hi all. I’ve just started using 3.5, haven’t gotten far yet but it’s beautiful and the updates look very impressive and non-trivial, so kudos to the team!

I sorely needed the condensing feature as I am currently engraving a large opera. I have the 3.0 manual bookmarked and went through the condensing section, and I read, as best I could at this point (I never saw version 3 until a few days ago), the relevant parts of the Dorico 3.5 Version History pdf.

I switched on “Condense divisi and adjacent players” in Layout Options > Players > Condensing. FYI going forward, each string section is split into desks A & B in the handwritten score and the composer wants them to stay that way. Dealing with labelling that well may be another topic sometime but for now you can just see they’re labelled things like “Vn. I I.II” or “Vc. I.II”. But anyway that will come, the problem right now is with condensing being either too much or too little and how to manage it on a finer scale than layout-wide. I left the player panel open in the shots so you can see how these are; the music of each individual player or section was entered on its own.

  1. Screen shot “undesirable condensing in contrabass”: Here contrabass desk A & B (labelled Contrabass/Cb. I.II) are condensing as are all the string section desks, but at the moment I wish the contrabass weren’t. It’s especially bad to the eye by measure 6 and no better in the second system below. I would like to be able to enforce no condensing while things are in this state, just temporarily. I see instructions on how to make a section condense and I am starting to grasp all the rules and conditions which you can set—this is all amazing—but I don’t see how to override it for just a period of bars or systems. (Obviously it’s early in the engraving, this is not when one makes page turns or condenses, so the systems may not break as they currently are shown. Still, in the end I think it will be necessary in this particular composition to make and un-make condensing here and there.)

I wanted to show a later point where I’d want to return to condensed Cb., then I came across something I did not expect to see…

  1. Screen shot “no condensing in cellos though they should be”: Look at the contrabass and let’s say the frame break for this page was actually at the third bar of the top system. From that point on it would be great to have the Cb. condensed of course. This is where I would elect to turn off any condensing override.

But then the new weird problem I noticed are the celli here. Both desks of Vc. are showing, not condensed, yet they are completely unison, every last note and rhythm the same. Shouldn’t these be condensed and marked “unis”?? What?

In trying to figure out what is happening here I could think of only one thing, though it isn’t a great or desired reason for keeping a section non-condensed for many pages.

  1. Screen shot “cellos begin to differ”: Pages later this unison playing in the cellos ends, and I should note that there have been no rests along the way. In this third screen shot, as of the second bar of the top system the cello music is different between the two desks—or technically with desk B’s slur tying the first bar’s last note to the second bar’s new different note and then resting. Here I can understand the non-condensed Vcs (though on looking at it it’s possible I’d want to experiment with condensing them since they could probably go together on one staff). Anyway, could this difference at this point and/or the rest in one desk and not the other be the reason for the heretofore non-condensing section? How do I override that? (FYI later on, after a group cello rest for bars, they do show condensed again.)

    I have other ancillary questions (like tuplet bracket behavior) but I hope to start with these. Mountains of thanks!

  1. I entirely agree. Add a Condensing Change and tell Dorico what you want it to do with your double basses.
    2 and 3. The manual’s pretty clear on this: (

If you add an empty condensing change (don’t flick any toggles in the dialog - just put a condensing change in) at the beginning of bar 46, Dorico will start a new phrase there, enabling it to process the previous however many bars with a different condensing approach.

Hey there, and thanks. I sometimes can’t find the way to do something because I don’t search the right phrasing in the online help or manual. Thing is when I search “Condensing Change” I don’t get anything clear. It’s a great label for the act of making a change to your condensing, though. I recommend that when the team develops a manual for 3.5 it should include a heading by the name of Condensing Change.

Anyway, how do I add one? Is there a page or place I can read where this is gone into?

Check page 24. “Condensing Changes” were just added in 3.5. And with the rapid development pace, the Version History is a stopgap until the online manual can catch up.

Condensing Changes were added in 3.1, but the manual’s a little behind. See page 4 of the 3.1 Version History rather than the one that Dan’s linked to.

Will do. Thank you BOTH

(a moment later) Engrave > Condensing Change… WOW! This is a whole new world, gonna take me a minute.

By the way, would you mind letting me know whether I was right in my guess about the reason behind the cello condensing/non-condensing behavior, the lack of rests for many systems?

You are absolutely correct in that guess - read the second paragraph in the screenshot I provided above.

I’m starting to get the hang of it, thank you.

Another question from this whole matter: Why do you suppose those tuplet brackets have appeared on the beamed tuplet 16ths? Tuplet brackets seem to have popped into existence only on the condensed staves and furthermore only on 16ths (maybe they’d be there on smaller values if I had them) but not 8ths. You can observe this in the 1st and 3rd screen shots above, most easily in the one “cellos begin to differ” where you see the Vn II condensed staff has these brackets while the non-condensed cello staves do not. This behavior extends to all instruments of all types; if they’re condensed and have that kind of tuplet, the brackets have appeared whether the voice’s stems are the same way or opposite. I checked every one of these yesterday before getting into condensing and these were all just 3’s without brackets. Even now if I go into galley view, or uncheck the Edit > Condensing, they change back to tuplet 3’s without brackets again.

I worry I’m running the risk of missing something obvious, but I think I’ve combed through the various Option dialogues and I can’t figure out what would apply to so specific a case. Brackets in Engraving Options are set to show only when necessary (and again this did all look right before condensing); condensing in the Options doesn’t help, nothing in condensing under Notation or Players > condensing under Layout.

As I understand it, condensed staves have an entirely different set of properties to uncondensed staves. Anything you’ve overridden in the properties panel for the uncondensed music will not automatically be overridden for the condensed music. You either need to go through and set those properties again on the condensed music, or set appropriate rules in Engraving/Notation Options. In this particular case, you’ll need to do it by hand; Dorico doesn’t have a rule for combining multiple tuplets (or some tupletted and some non-tupletted notes) under one beam without a bracket.

Ah, too bad for these fingers but at least it’s not a mystery. I notice too that condensed passages cannot be selected in Write mode (makes sense) so I’ll have to go through and command-click the bracketed 16th tuplets then change their appearance in the bottom panel. Or use Select More which will select more of the same thing on the same staff and voice throughout the flow. Of course it will also select tuplets of other sizes, and of course you want the brackets on tuplet quarter notes and larger, but nonetheless it may save time as there’s less to deselect than select in this case.