Condensing: rests

I’m slightly out of my depth with Condensing.

I have lots of phrases where just the 1st instrument plays, following a rest.

Instead of giving me a full bar’s rest for player 2, Dorico splits out the first beat. I can’t find a way to stop this.

As usual, a file is worth a thousand pictures (especially when dealing with condensing) :wink:
Have you tried putting a manual condensing change at the very beginning of that bar?

What should the change do?

I can’t see any relevant options.

This might help (I don’t know for certain, though) -
Notation Options > Rests > Rest Positioning > Coincident rests of the same duration in opposing voices: > Show only one rest

No: I already had that setting. I tried the opposite.

I can’t share the file, I’m afraid, but I’m hoping the behaviour/problem will be recognised.

The only condensing option I can see is to exclude the rests of the 2nd player altogether.

This did it for me for a similar situation. You might have to “reset” afterwords.

1 Like

Yes, that works perfectly! Though … isn’t ‘Up for 1, Down for 2’ the default, in any case?

It basically means I have to manually define that for a whole bunch of instruments.

I cannot replicate the behaviour you see. I get this with factory settings.

You’re right: I get the same as you in a new document.

It’s a project file I’ve been given; and I can’t just reset it. I’ll see if the Library Manager can yield some info.

Is this perhaps another xml import problem?

No: I think it was created from scratch.

When I tried that, the order of items in the right-hand column was this initially:

and it resulted in the behaviour which Ben was seeing.

When I clicked on the Flute 2, held for a couple of seconds and then dragged it to underneath Down-Stem Voice, as here:

the condensing changed to a whole rest for the Flute player in the condensed staff.

Except that I’m not getting two up-stems anywhere else.

I’ve reset the Notation Options in the document to my defaults, but it’s still creating all those rests without the manual change. Hmm.

Arrgh: and the manual change is causing using problems.

What does it look like in galley? Are any properties set for the rests?

They’re implicit rests. All in Up-stem 1 in Galley.

Unless I can find the global cause, I’m having to manually set the stems every time there’s 1 player, and then reset them for unisons!

Up against a deadline and nearly finished. Will have time investigating later!

I suspect you may be encountering the problem I described in this post:


That’s it!
So it can be ‘fixed’ by moving one instrument to a different voice…?

Yes: I think that’s the issue. They are all preceded by a2 unisons.


Here is an example that shows how one condensed phrase ends can influence the way the next one begins:

Bars 3 and 5 show whole rests for the inactive player because the phrases in bars 2 and 4 end with one instrument not playing or with two instruments in different voices. Bars 7 and 9 do not show whole rests for the inactive player because the phrases in bars 6 and 8 end with both instruments playing and sharing a voice.