Condensing should combine identical System Text

Should combine System Text if it is identical in content.
Example (also shows text collisions):
Screen Shot 2024-05-02 at 2.28.55 PM

Additionally see how the bottom “Straight Mutes” text has a number in front (Why? Perhaps Dorico got confused in condensing).

Do you mean staff text?

I feel like I had a similar scenario last week and it did condense. [Edit: I was using playing techniques but staff-attached text, if at the same position, should condense too]

On the Condensing page of Notation Options, make sure the option to consolidate text items is activated.

@superblonde You deleted the notes in your example, so I am not sure what is going on. If you have different rhythms in the condensed staves where the same Playback Technique is used, and have the Notation Option/Condensing/Amalgamation approach for playing techniques set on Prevent amalgamation, then you will have duplicates of the PT. Try to set it to Allow Amalgamation. If it doesn’t work, please post a file.

Same example with Prevent Amalgamation:

It isn’t a Playing Technique. I could make it that but it does not have to be. It is shift-X text. The contents of the text are independent, maybe it is a descriptive direction, in my example it just happens to be a direction to use mutes (which could be a Playing Technique but again I chose not to do that). Ideally, same Text should condense (and not collide either).

Galley view:
Screen Shot 2024-05-02 at 3.11.06 PM

Galley view additionally shows the border, which the Page View does not. (Why no border? I don’t know. The border shows in normal score Page View; but, not in the Condensing score. But also just for some texts, as my other Texts do have borders, in any layout and any view. But, those texts with borders are only on their own stave, and not part of a condensed staff.)

Seems not.

@superblonde
This has (similar to the pt above) to do with the use of the same rhythm or different rhythms on the music at the moment when the staff text occurs.

If you have only rests before/during the staff text occurrence, it seems that Dorico remembers the different rhythms that appeared before, and doesn’t amalgamate staff text (1).

If you have the same rhythms before the rests where the staff text occurs, it amalgamates the staff text (2).

If I use the same rhythms in the place where staff text occurs, even if before you had different rhythms, it will be amalgamated (3):


2.

3.


For the border: if you create a Paragraph Style with border, and use it for your Staff text, it will show the border also in the condensing view. (the border applied with the properties panel seems to be lost with condensing)

It does.

  • When I condense music that contains staff-text with no border: it works as expected.
  • When I condense music that contains staff-text with a border added in Properties: it works but the border disappears.
  • When I condense music that contains staff-text where the paragraph style has a border: it works as expected.

@superblonde if you select the condensed-borderless text in Engrave mode, you can switch the border property on. Be careful though: activating the property in Engrave mode could cause the text to act differently when not condensed e.g. you can have regular text condensed, turn on the border in Engrave mode when it’s condensed, but if you turn condensing off then the border will disappear.

I copy-pasted the exact object to the other staves. There is no rhythmic discrepancy. This case is also at mm1 so there is also no rhythm before.

@superblonde

I cannot reproduce this issue: it amalgamates nicely if I write the staff text on the rests at measure 1 (with or without rhythmic discrepancy after the text position), and Duplicate to the other condensed staves. As I said you are free to share an example (Dorico file) of your issue for further investigation.

(Meanwhile you can always hide the redundant text with the properties panel).

ok, well, it seems there is a bug then.
I created a new flow and the identical system text did condense at mm1 in the new flow (but without border which is a secondary bug).
Screen Shot 2024-05-02 at 4.47.48 PM

Screen Shot 2024-05-02 at 4.48.41 PM

Then I return to my working first flow and deleted the old Text and created new identical system Text (with border) and it does not condense. The additional giveaway that there is a bug being that there is a “1.” in the text where there should not be. I changed to using playing technique which does properly condense the playing technique.

Screen Shot 2024-05-02 at 4.49.59 PM

Screen Shot 2024-05-02 at 4.50.21 PM

I think you need to upload a project before you can call it a bug. We can’t reproduce it.

1 Like

That is not a bug. Dorico considers the condensed versions of objects to have their own properties (basically they are different objects).
That is necessary, because you want to be able to set some properties totally different in a condensed layout than an uncondensed layout.
Of course it’s arguable which properties should be different and if the border should be one of them, but the principle holds.

If you use a paragraph style with a border defined there, the border should show, though (IIRC)