Condensing stopped playback — HELP!

Hello, All,

I hope to heaven that I’m just overlooking something obvious, but I condensed the score I’m working on to see what it would look like, and after that, the playback only works on the staves that weren’t condensed. And that is the case even when I “uncondense” the score — none of the staves that were condensed will play back.

I’m working on a deadline (aren’t we all, always?!), and I need the playback.

Thanks much.

You’re not trying to play solo/soli sections are you?

Condensing should have absolutely no impact on playback - it should play back all the players that are in the current layout. Have you switched to a different layout?

I don’t know enough about solo/soli to answer that, Leo, except to say that I’ve never had this happen before, and I started with Dorico 1. Dorico has always just played back all the notes in the score. But I’m even more confused now (11:35 EDT, U.S.)

I had a total mess going. As of a few minutes ago, the below was the status:

NotePerformer will no longer play back ANY SOUNDS at all, and I can’t select it in the playback template list — it’s not there;
DoricoBeep plays back ALL STAVES in that painfully loud, MIDI-ish sounding way;
HALion Sonic SE plays back ONLY THE STAVES that weren’t condensed, and the sound is also a MIDI-ish, swooping sound;
Symphonic Orchestra plays back ALL STAVES in a relatively pleasant/usable set of sounds, but they aren’t the instruments indicated — they all sound like string sounds. (This is a concert band score, btw.) I can at least use this one to listen to pitches, which puts me better off than I was.

However, I tried restarting, and I now at least have a workable sound going — HALion Sonic SE is playing back all the staves, and in the same old sounds I was used to. It certainly isn’t Noteperformer, but at least I can use it.

I did do the thing that Daniel posted to get NotePerformer to work, and it was fine until I did the condensing thing.

And finally, although I don’t think it will fix the NotePerformer-not-working problem, can you give me or point me to a simple explanation of the solo/soli issue? Although again, I’ve never messed with that or had a problem of that kind — Dorico has always played back everything I have written.


No, Paul, I’m in the same score (and it’s the only score layout in the project) I was using yesterday.

Thanks for the suggestion.

I was just asking if you were trying to get individual staves or groups of staves to play back, which you typically do by selecting individual staves. You can’t select condensed staves - you can’t even marquee select them - hence the question.

Ah, I see, Leo.

No, I was just selecting a whole rest in one staff, my usual method of playing back everything.

And I was in uncondensed mode; but the previously condensed staves wouldn’t play. That’s no longer the case after the restart.

Dear Lew,
Notice that it is much easier now to make Dorico 3 play everything than it was before. If you select a note (and it does not matter if something else is selected along) it will play everything. You now need to select different notes at different rhythmic positions to make this/theses voice/s play solo.

OK, I am now beyond frustrated. NotePerformer doesn’t play at all, and HALion just gives me buzzy synth-type sounds.

Nothing I do makes NotePerformer available in the Play:Playback Template window — it’s just not there. And the Halion sounds were working ok before, but not now.

I’d really appreciate some basic how-too advice/instruction. I am the first to admit I don’t know how to get “under the hood” in the playback stuff, so nothing anyone can tell me will be at too elementary a level.

Thanks much.

The first thing to try is to quite everything and restart your Mac. That might set things straight.

If that doesn’t help, quit Dorico again, and in the Finder go to /Users/your-username/Library/Preferences and find the folder VSTAudioEngine3. Trash this. Now restart Dorico again.

If that doesn’t help, try creating a new project and add an instrument like a piano, and add a few notes. Do you get playback in that project? If you do, then try reopening the project you’re working on, go to Play > Playback Template and try applying the default HSSE+HSO (Pro) playback template.

If you don’t get playback in that simple piano project, zip it up and attach it here. Also do Help > Create Diagnostic Report and attach the resulting zip file here too.

Thanks, Daniel. I’ll give it a try when I get home.

Just an idea - have you used the NotePerformer patch .zip file from the sticky thread of the Dorico forum?

At first I didn’t and had reinstalled NotePerformer and it seemed to work but it probably wasn’t working 100%. You need to use the .zip file to ensure everything works properly in Dorico 3.

If you mean the .zip file Daniel posted, yes I have. Twice. But thanks for the suggestion.

What I haven’t had time to do yet is try Daniel’s advice (above) about restarting everything including my computer. I’m really hoping that will work.

OK, I now have the HALion sounds working, so at least I can do my work. However, I GREATLY (as does most everyone else) prefer to use Note Performer.

I have gone through the process Daniel posted re: inserting the zip file into the correct folder on my Mac and unzipping, which creates the two folders Daniel said it would create. However, when I try to set the playback to Note Performer, it isn’t possible. I can choose Performer from the dropdown VST Instruments menus, but nothing plays — just silence. And when I try to set the Playback Template to Note Performer, it isn’t there to choose; there are only HALion or Silence.

How do I reinstall NotePerformer so that it will work on Dorico 3?

Thanks very much, as always.


After unzipping the zip file as per the steps in the instructions, you should have a folder /Library/Application Support/Steinberg/Dorico 3

In that folder you should have only two subfolders, PlaybackTemplateGenerators and PluginPresetLibraries (which contain other subfolders with files you need).

You can check to make sure you have those two subfolders by doing the following in Finder: Go > Go to Folder, and type “/Library/Application Support/Steinberg/Dorico 3” without the quotes and click Go. If things are set up correctly, you should see those two folders (and only those two folders) immediately after doing that.

If instead you have a Dorico 3 subfolder inside the Dorico 3 folder, you’ll have to move that up one level, so that you have PlaybackTemplateGenerators and PluginPresetLibraries subfolders directly inside /Library/Application Support/Steinberg/Dorico 3 (instead of being in /Library/Application Support/Steinberg/Dorico 3/Dorico 3, which is incorrect)

Thanks, mducharme — I’ll check it.

Note also (as this has caught others out) that if you reinstall NotePerformer after doing that unzip step, then it will overwrite the files you unzipped.

OK, problem finally solved. mducharme, thank you for the specific path to the folders. When I was unzipping the file Daniel provided, it wasn’t creating the two necessary folders in the same place as the zipped file was; instead, it was creating them in the download folder.

Once I moved them into the correct Steinberg library file, everything worked as it was supposed to.

Many thanks to all who spent time helping me figure this out, and especially to the Steinberg folks. I’ve said over and over, as have many others, but I’ve never experienced the level of customer support in any of the other hundreds of applications I’ve worked with in my life as good, willing, and effective as that provided by the Dorico team.