Condensing - unwanted a2 a3

Any suggestions as to why condensing is creating all these unnecessary a2 and a3s?
I haven’t seen reference to this in the forum.

That is an irritating side effect of the fact that condensing works by dividing the music into “phrases” which are separated by rests, and decides how to condense each phrase independently.

I’m hoping that future updates will allow more control over this issue - at least to be able to hide them independently (or show one, then hide subsequent markings).

You already can hide them independently. In Engrave mode, select the culprits and in the properties panel, tick “Hide”.

Any updates on how to fix this? I’m having the same issue with extra a2s. I can, of course, hide the extra ones in Engrave mode, but I’m hoping there’s a better way?
Here’s an example of what’s happening:

With factory Notation Options and Engraving Options, in Dorico 3.5 (even 3.5.0) you should get this:

We can’t divine how your options are set, or how you came to achieve your result solely from a picture. Please either upload the project or explain your settings.

Thanks! I just have the default settings for condensing in Notation Options, Layout Options, and Engraving Options.

In that case, do you have any Condensing Changes, and if so, what’s going on in them?

Yes, I have manually condensed the two parts (Bassoons 1 and 2). I have a third Bassoon staff that I have not condensed with Bassoons 1 and 2.

If this condensing (1+2, 3 separate) applies throughout the project, set this as a custom condensing group in Layout Options, rather than via manual condensing.

If this changes from system to system or from page to page, use the Notation Options (either in the general Notation Options dialog or in the Condensing Change dialog) to persuade Dorico to split the music across two staves the way you’d like, but by changing the automated options rather than via manual condensing.

Manual Condensing should be used as a last resort, as it ties Dorico’s hands behind its back. As a byproduct of you telling it not to apply its usual condensing rules (which you do have control over) you get redundant labels, as shown above.

1 Like

Thank you! I’ll try making a custom condensing group in Layout Options! And I’ll try to find the right Notation and Condensing Change dialog options as well.