Confused about Record Enable on MIDI Editor Open

When I double click on a MIDI part to open the MIDI editor, the MIDI track is Record Enabled.
This is regardless of the setting “Solo Record in MIDI Editors”.
Is this supposed to happen?

Concerning “Solo Record in MIDI Editors”, the manual says “If this is activated, when you open a MIDI part, it’s track is record enabled, furthermore, record enable is de-activated for all other MIDI tracks until you close the editor”
That is not how it is working for me, however. No matter what, when I open a MIDI part in the editor, the track is record enabled. If the editor loses focus (but is still open), the record enable is de-activated. When I click on the editor again, to bring it into focus, the record enable is activated again. Either I am mis-understanding the description in the manual or it is not behaving properly.

I don’t remember, in the past, record enable being activated when I opened the MIDI editor. It is possible that I just never noticed it before because the editor is usually covering the track list.
I have tried trashing the preferences and tried using an old set of “backup” preferences, no change.

The only thing I can think of that has changed since I noticed this is that I upgraded from Komplete 6 to Komplete 8.

I have searched and read some other threads about tracks becoming record enabled (for several different reasons) and this one seems to explain my case exactly.
It is somewhat inconclusive as to whether it is normal behavior though. I guess it does make some sense that editing using the key editor is essentially the same as recording (i.e. changing the data on the track) which supports the need to have the track record enabled.

It isn’t even really a problem, to be honest, I just really want to know if my system is behaving normally.
Does the track become record enabled when you open a part in the MIDI editor?

My Cubase 4 behaves just like yours. If I understand the quote you extracted from the manual, this must be a bug.