Confusing note input behaviour (dotted notes)

When I am inputting notes I can press numbers to change duration of the next note. But pressing a dot changes the last note which is still selected. Why is it like this? Is there an option to disable this? At least when caret is active.

There’s a setting for this at Preferences (on the Edit menu) > Note Input and Editing > Specify accidental, rhythm dot and articulations.

If I remember correctly, this setting can sometimes change if you switch to pitch before duration.

Thank you!

That did the trick.