"Connect to Macro Page" menu doesn't work

According to the online manual of HALion 6:

https://steinberg.help/halion/v6/en/halion/topics/macro_page_designer/macro_page_designer_connecting_controls_to_parameters_from_within_an_editor_c.html?hl=connect%2Cmacro%2Cpage

Connecting Parameters Via an Editor in HALion

  1. Right-click a control in the Sound Editor, Zone Editor, etc. and select Connect to Macro Page.

  2. In the GUI Tree, navigate to the control that you want to connect to the parameter, right-click the value property in the Properties section, and select Connect to Parameter .

If you now click the value field, it shows the parameter ID of the connected HALion parameter.

However, this never works in my case. (HALion 6.1.0.72, HALion Standalone 2.5.10.35, macOS 10.13.3 and Windows 10 build 17115.)
The steps I did were following instructions from this video: https://youtu.be/mi8gpGoY3Ds?t=1m19s

I could drag a parameter from the PARAMSLIST to a specified macro page control to connect them.
Now this issue blocks my possibility of binding a macro page control to a parameter that is not listed in the PARAMSLIST.
(I was trying to add a control to let the headroom amount be controllable in HALion Sonic SE.)

Update: I confirm that downgrading on the first public build of HALion 6 could bypass this issue. However I found that I could only bind the headroom settings of one zone (but not an entire layer) to a control.

I cam confirm I have this issue as well.

Hi ShikiSuen,
I’m able to reproduce it here. Its now in our Defect-Tracking-System and listed as Bug-ID “HALLY-7341”.
I hope we can provide a fix for it soon.

Thanks for your report and please accept my apologies for any inconvenience caused.
Gerrit Junge

Hi there,
I found out that there’s a workaround to make “Connect to Macro Page” work.
Simply click on “TEMPLATES” in the upper left corner of the Macro Page Designer to open the “show Templates” tab before you choose “Connect to Macro Page” from the context menu and voilà, it works.

best regards
Gerrit Junge

Thanks! This work around does indeed work!