connection drops out after 3 minutes

hey all,

long time VST connect user here. after a thourough setup process a few years ago, i used to use connect SE in cubase 7 and for these few years (and countless records), i used this same template over and over, with very little trouble. maybe the occasional dropout depending on the connection of the performer, but overall a very workable solution.

now with all the OSX updates and performer client updates and also myself having moved on several cubase versions, this is no longer an option. so now im using cubase 9 and connect PRO. i figured, lets get rid of the silly connection code numbers and do it via account, and enjoy the flexibility and auto setup of the much better integration in cubase 9. also, the current day performer clients wouldnt connect to my old template anymore, so i was basically forced to this.

unfortunately, i ran into a few problems, which i really need to fix because VST connect has become such a cruical part of the workflow with several of my clients (who all love me and steinberg for this amazing tool):

  1. most importantly: after some troubleshooting, i have it at the point where i can launch my template, find my client in my friend list, were connected, sync LEDS and all run fine, latency and delay is all good, it basically works perfectly. but after around 2,5 minutes, on MY side the connection drops. connect then says “server not responding” and then “make sure you are connected to the internet”. yet, of course, i am. any other internet related things still work.
  2. if i could simply reconnect, it would be tolerable, but once this has happened, i have to shut down and restart cubase completely for that to happen. otherwise i will just get 20 seconds of a busy mouse cursor and the “server not responding” dialog shows up again.
  3. when restarting cubase and reloading the template project, it works again. but not for long. repeat.

obviously, “i cant work like this” :wink: is this a known issue? is there anything i can do? maybe even something more complex like reserving ports or some router or firewall configuration stuff? not an expert on this stuff, but not completely ignorant either, so any tips are much welcome.

finally, the lesser problem is this: other than with my old connect SE setup, the monitoring of the singers mic is only on the left side. for the life of me, i cant figure out how to change that. any tips?

We are looking into this. One question: does that message also appear when you connect using the ‘old style’ key code connection method?
As for Performer only left channel: select the dedicated mono input on the Performer input channel (top of strip), or set the tiny pan position slider in the recording section above the Performer Monitor. Some more tips can also be found at

Thank you very much!

  1. Yes, I tried both connecting via code as well as via “invite friend”. No difference. Any help is much appreciated, as I currently can’t use connect like this, which unfortunately indeed is interrupting some projects (but that’s a risk one takes when you decide to let your work depend on complex tech, so please don’t read this as me being whiny about this… Just asking for help because im out of ideas)

  2. I seem to have some sort of double routing. Those settings were the first I went to, but they did not work as expected. Or rather, there seems to be some part of the signal flow that ends up on my main monitor out either way. It’s kind of difficult to follow with all the changes in the way Vst connects integration in the control room has been changing over time (allthough steinbergs ongoing efforts to continually improve this are much appreciated).

A clear indicator of a double signal flow is that I can gradually “force” the signal into the center by adding additional monitoring strips in the connect Plugin, and set them all to the same mono input, thereby adding signal on the other pan side to the “leaking” monitoring signal that’s only on the left.

Must be missing something really obvious here. I can smell the upcoming “duuuh!” a mile from here :wink:

I am a bit confused.
a) the message you mentioned only ever exists if you connected via the friends page, not when you connect via keycode. So either you have previously logged in with your mySteinberg account, or the message text is different. You should be able to connect via keycode w/o logging in, right?
b) I told you to use a mono input for the Performe channel. Also it looks like you always try to use your old template, you are advised to try an empty project, apply „Create VST Connect“ and not use track monitors on Performer tracks.
Does that help?

It does not work to connect via code if you had logged in with your account before, not even after you log out again, since the checkmark icon that you use to connect via code disappears once you have logged in via account (not sure whether that’s supposed to be a feature or a bug, allthough I personally would put my money on the latter).
The error appears either way. Even weirder, it can even appear after I logged out, and at one point, I had logged out, but apparently behind the scenes the program had failed to do so and my counterpart connected to me anyway.

Overall, it’s just rather shaky, the whole thing. Has there been bugfixing related to VST connect in 9.5? Still on 9.x

No, im not using my old template. Im setting up a new one and of course I begin with an empty project and then use the create VST connect function.

Good bet :slight_smile:

That may happen because of the mixture of the two connection options.

We checked all possible scenarios. If you strictly follow this path: do not login but get a keycode; Performer also must not login (not even “accidently”) but only use the provided keycode. In that case, the message you mentioned can not be issued at all. Either the text of the message is different (which would point us developers to an entirely different direction!) or there is something very specific about your environment (like running VST Transit at the same time).

Did you at least succeed with the “signal left only” by using a Mono Input?

We want to help and really tried hard to reproduce your problem but so far there is no possible path to that message.

for some reason my email notification seems to have been turned off, so, sorry for missing this helpful post!

i will try what you suggested next time i have a connect session. lots of those coming up in the coming months (assuming i get it to work again). i use this feature quite a lot usually, been recording the vocals for countless records with connect.