Constant dropouts, tempo staggers and glitches

Everything I playback in N5.5.3 suffers from audio glitches and dropouts.

I’m running at 48khz sample rate, 24bit resolution and 25fps.

My interface is an RME Fireface UFX set to a buffer size of 1024 samples which gives an input latency of 21.896ms and an output latency of 22.750ms, so the buffer size is not set too low in this instance.

If I play audio directly through the RME using the Totalmix software there are no glitches, so I don’t think the problems are related to the RME- it must be something within Nuendo.

I used to record everything at a sample rate of 44.1khz, but after converting older recording within N5 to 48khz the problems are still there.

New recordings made at 48khz all have the same problem.

Am I being stupid and missing something obvious?

The system was working perfectly until recently.

Any suggestions will be much appreciated.

Probably a CLOCK issue?

I think you are correct - but what should I be checking?

All your digital devices should be clocked at 48Khz…
have you got more than one digital device connected to each other? and a clock master?

The problem has been resolved by un-checking ‘Multi Processing’ on the Device Setup\VST Audio System menu!

There is very little help about this option, but it does state that "If activated, Nuendo will automatically distribute the processing evenly between all CPUs for optimum performance. This sounds like a plus to me. My system has 8x CPU’s so should benefit from the option being checked. Unfortumately, with it checked there are constant performance spikes that cause audio glitches.

With the option un-checked will all plugins just use a single CPU?

If I recall correctly this is a “complicated” topic. You’d need to do some digging to find the best answers to your questions.

There’s also something that involves, or did involve, the UAD cards as far as I recall…

Hi Lydiot,

You’re right - I’ve just had a look around the forum and there are loads of posts about the 'Multi Processing ’ option - very confusing.

I’m monitoring the 8 CPUs now (numbered 0-7). With 'Multi Processing ’ un-checked most action seems to be in the first CPU ( 0 ) although there is still some activity in the other ones, although this may not have anything to do with Nuendo. Some of the CPUs ( 1, 3, 5 and 7) are marked as ‘Parked’ but there is still some movement on them.

With 'Multi Processing ’ checked there is more action in more of the CPUs, but the whole system staggers and glitches in an un-usable way.

Why could this be?

If ‘Multi Processing’ is supposed to spread the CPU load between all available CPUs, I wonder why it makes the system run so badly?

With only one usable CPU I’m asking myself why I need the other 7 !

What happened recently? Changed drivers, upgraded nuendo?

I have no problems here with 5.5.3 other than a few random crashes, maybe 2/week.


have you also looked into the UAD software? I believe there’s a setting somewhere that can help out. Perhaps it got reset during a software update or something…?

Hi Lydiot,

There is an option called ‘ Enable CPU Optimation’ on the UAD Configuration page, but un-checking it makes things worse.

For now things are working after un-checking ‘Multi Processing’ on the N5 Device Setup\VST Audio System menu.

I wonder if anyone at Steinberg can explain exactly how the ‘Multi Processing’ option is supposed to work these days.

Turning off the Multi-Processing option is the wrong way to solve the problem. You will only get a fraction of the performance from your processor.

There are several things to try. You may want to see if disabling HT (Hyper-threading) in you BIOS helps. While there are many benchmarks showing that HT on improves performance, my experience on my i7 system has shown improvement with HT off (much to my surprise). It is easy to change back and forth, so it is worth a shot.

You should also look into possibly disabling the Turbo-boost, C1, EIST etc. on you motherboard. Depending on which version of i7 you have, this could make a big difference. I believe this does not necessarily apply to the new Sandy Bridge versions.

Another thing to do is to run the DPC latency application. Search for DPC latency Checker and you will find it. You should be able to get under 100uS or better. I can get really low DPC numbers if I disable HPET in the BIOS, but I never saw any improvement in real world use and disabling HPET supposedly give you less accurate timing for things like MIDI, so I leave it on.

Video cards and their drivers could also be wreaking havoc for you. I’ve also improved things by changing the hard drive settings as well. Lots of things to mess with.

Hope this helps…