Control elements disappear on Macropage after saving

Well, I guess, the title gives a clue about an issue I have here.

While working on a project (with multiple pages/stacks and Disable groups) I saved it as Halion program and afterwards as Halion Sonic SE Layer preset.
After re-opening in Halion 6 as program all but one control element disappear. I can make them visible again changing the position of every element in the GUI tree, but this works only until the next Save Program and Reopening.

I tried to import the Halion Sonic SE Layer instead of the program, with the same result.
Importing the Halion Sonic SE Layer does not show those GUI elements either.
Am I missing something?


About the images:
The three switches on the left side below are only on/off switches, while the six on the right are for changing the GUI page using Stacks.

System: Win 7 SP1. Intel Xeon 6core, 8 GB RAM.
GUI elements after saving.png
GUI elements before saving.png

Hi Roger,

Can you upload the preset?

It looks like you are using quite a lot of groups. The hierarchy in gui tree is very important when using stack and disable. Check the element that is disappearing is in the correct group and doesn’t get covered by any other element.

Actually I suspected some misbehaviour of the groups, so I eliminated them completely. In other words, every element is now directly on the same level in the stack. So no groups anymore.

Also, I am sure, there are no elements covering other elements. I simply move one disappeared element, an voila it re-appears, and it works as it should, but reloading the program later this behaviour continues.

All the best.