Control room : duplicated click sound when listening to cues from main section

Hello Steinies,
When I’m using control room, recording a musician, with click enabled both in his/her section (Cue 1) and in my monitoring section (Main) : if I fast check the musican’s headphones (clicking on “C1” button in main monitoring section) I hear his/her cue + his/her click sound… + my click sound ! Click is always “bigger” thant its real level. I have to :

  1. turn off my click
  2. click on C1
  3. check what I need to check
  4. click on “Mix”
  5. turn on my click

Don’t you think that engineer’s click should be muted automatically when checking cues ?

Yes that’s true…