Controller MIDI signal is reaching C12 Pro, but not Remote Editor?

Hi, I set up a virtual button in the Remote Editor (pressing the button on my keyboard in “Placement Mode” while editing the controller did cause the shape to appear), that part went fine.

When I opened the Mapping Assistant however (unlike other buttons, faders, and Knobs which I set up to work great as controllers), I run into problems when I try to link any one of three specific keyboard buttons to a Cubase function.

The first thing that seems to go wrong is that pressing the keyboard button doesn’t turn the virtual button blue in the Mapping Assistant.

So, to map the virtual button in the Mapping Assistant I have to use my mouse click to turn it blue.

Then, even after mapping it to a Cubase function in the Mapping Assistant, the hardware button is not functional.

The thing is, I notice when I push the hardware button, Cubase shows it is receiving a MIDI signal.

I’ve gotten other hardware mappings to work just great, just stumped on getting these three buttons to work.

Probably relevant: These three buttons were originally “pre-mapped” by Roland to control specific Cubase transport functions.

Roland Juno-DS88.

Any suggestions please?

Thank you!

What exactly are these buttons sending?

1 Like

Before reassigning, Roland had them set to send:

  1. Return to zero (my phrasing)
  2. Play/Stop
  3. Record enable

I have tried to reset them to Key Commands:
1)Mixer >>Expand>> Routing
2)Mixer >>Expand>> Inserts
3)Mixer >>Expand>> Gains

Thanks for asking, @mlib !

I guess you have setup a mackie for the Juno, this is actually how it communicates with Cubase.

So, since you’re building up your own remote, you should actually deactivate this mackie device in your setup or at least set its ports to none, because upon receiving the midi signals, this devices consumes them and never arrive to your remote.

1 Like