Controlroom phones and preview

When using the phones output from the control room, there is no audio when using the preview function. When I enable the “Use phones channel als preview channel” setting, I DO hear the preview on the phones, but it is no longer audible in the main montitors output. Is there a way to have both the phones output and the main monitor output behave in the same way without having to change this setting every time?

I guess it’s not possible, but would be handy
Maybe a setting in the control room section with a key command…

Would you add the feature-request tag please?