Copy/Paste text from Wavelab clip/marker menu

I don’t know why but I’ve noticed lately that copying and pasting titles from the Wavelab clip tab/menu into something like an email, results in something other than text being pasted.

If I copy a clip name in Wavelab, and paste into an email for example, Apple Mail thinks it’s a contact file from address book. If I paste that in the CD-Text editor box, sometimes it pastes as some big long string of text that I can’t even see all of but contains things like <xml and lots of other spaces and characters.

Do I have something set incorrectly or am I copying a clip name incorrectly? I can only reproduce the mail paste issue now but next time I get the issue in other form, I’ll take a picture of it.

Here’s the result when I “copy” a clip title, and attempt to paste it in an email in Apple Mail.

This didn’t happen before as I quite often copy and paste titles from the clip or marker tab for various reasons…sometimes pasting elsewhere in Wavelab, sometimes in an email.
Screen Shot 2015-05-27 at 4.57.26 PM.png

I get the xml if I select a clip in the montage track and ctrl-c. Maybe something to do with that? If I select the clip name or double click the clip name in the clip list before ctrl-c it comes out ok. I only tried this on Windows.

Thanks for the info Bob.

I seem to be getting the XML data even when selecting the clip name in the list/menu and attempting to paste it in certain places.

Maybe a Yosemite thing? Doesn’t happen to me with Wavelab 8.5.20 on Mountain Lion. Pasting in Mac Mail and TextEdit gives same result as on Windows. What you’re seeing seems to be a documented problem, maybe only related to certain programs (like Wavelab) but I don’t know where is the fault:

https://discussions.apple.com/thread/6670253

The last poster says the programs are at fault, not Yosemite, but it’s probably a matter of opinion.

My only comment is that on a mac running Yosemite and Office for Mac I experience this also … outside WL. Between Office applications for example. Outlook to Word it happens a bit. That computer does not even have WL installed on it.

Never happens on my studio PC.

FWIW rant: I have had an irrational, strong preference for Macs for a period resembling forever. But the recent new OSX stuff really has me starting to think PC.

My job is supporting both Mac and PC desktops and servers. This year I have had major disruptions of PC desktops, PC servers and Mac desktops caused by faulty updates; the main difference is that Microsoft acknowledge their problems publicly much faster than Apple do. Either way, there is no escape…

Paul

Not sure if this is the last word on the subject, but the following says the .vcf paste in Apple Mail is an Apple problem, and bug reports have been filed with Apple:
https://github.com/Swordfish90/cool-retro-term/issues/202
I couldn’t originally figure out what a Radar was in the Apple Discussion thread, but I guess it’s something that’s filed with Apple. But maybe it’s a program problem too. I don’t know. If Apple hasn’t fixed it yet, maybe they don’t consider it their problem.

The XML problem in Wavelab might be a separate problem. Like I said I also get exactly the same XML paste in 8.0.4 on Windows, but only if a selected clip is copied in the montage, and then pasted into a text editor. So that might have some bearing on what you’re seeing, although what you’re seeing seems to get mixed up between clip list selection, and montage clip selection, so definitely sounds wrong.