Copying voices exactly as they are

I have a simple problem, but can’t find a solution anywhere: I copy the top line to the bottom and want the same display, i.e. 2 different voices. I tried 2 methods (paste and paste special) and always have the change that everything becomes the same voice and the note stems are changed. I also tried changing the bottom voice to a “next voice”, and then edit. No success. I search and search… but without result.!!Bildschirmfoto 2021-02-22 um 20.46.28

You tried Paste Special—Paste Into Voice—New downstem voice?

Yes, as you say. Also "duplicate to “next” staff. Sorry, I opened the german version, and can’t translate the exact wording.

Ok, now I see the picture. That’s odd. If you copy the entire thing and paste it into a blank staff, Dorico should always respect the previous voices. That’s the expected behavior. I’m not sure what to suggest differently.

You’re sure you copied all notes in that measure, copied, and selected a blank measure to paste them into?

Now I tried your advice: It worked as you say! On a blank staff it’s okay. Thank you.

  1. Could you tell me a workout
    to change the original voice (for I have multiple flows and would like to abreviate the work)

  2. Do you know a method to realize such changes to multiple flows simultaneously?

1 Like

Glad to hear it worked! It sometimes takes time to learn all the way that you can work with voices in Dorico, but once you learn, it’s quite useful.

You can select a group of notes, right-click, and select Voices–Change voice. You can assign them to a new voice.

I suggest turning on View–Voice Colors to show you which voices are which.

Oh, by the way… welcome to the forum.

If I select the lower voice by filter oder selecting individual the result is this. (see picture). Then I tried to “overhelm” the upper voice vice versa: the stems all looked as before!

I think I have to “create” a fresh staff on all flows and to copy it one after the other. Many thanks again for your help!

Yes, it’s my first try to get answers this way.

Did you perhaps flip the upper notes by pressing F? If so, that’s not what you want to do.

In the alto sax staff, select one of the upper notes. What does the read-out say in the status bar: up-stem voice or down-stem voice?

I’m sorry, - I had to leave the screen.

“Flip” is nearly the solution after separing the voices! Only the tied notes remain in the “old” status! (strange!) Bildschirmfoto 2021-02-23 um 00.49.21|690x222

In the original “wrong” score the status bar says: “Up-stem voice 1” to both notes.

Workaround now: >edit />filter / >notes in chords / >bottom notes

edit / >voice / >change voice / >change voice to next voice in the staff / >flip

To make a new staff and option/click is the simplest and fastest way to handle “my problem”.
Thank you dankreider!!

Addition: the problem of changing the voices when copying only appears when using the context menu and executing >“paste special” - >“move to staff above/below” or >“duplicate to staff above/below”. When duplicating with the >“opt/click” or >“cmd/c” + “cmd/v” method, the duplicate corresponds exactly to the template. What might have been the intention of the programmers? I would prefer the exact duplicate and handle the voices afterwards if necessary.

Maybe I agree. After all, if I want the result in a different voice from the original, I can choose ‘Paste into Voice’, or change the voice afterwards. Unexpected changes are confusing.
But I’m also trying to come up with counter-arguments.