Copying with triplets

Hello,

I know that this has been discussed before but as far as I could find, not this particular situation.

I have a 4/4 measure with two voices, where the second voice enters on the second beat with a 8-note triplet. This triplet is set to “start voice” on the first note and “end voice” on the last note. The first voice also has some triplets.

When I copy this measure, the 2nd voice triplet won’t copy. Everything is selected including the triplet “3”.
If I switch off “start voice” and “end voice” in voice 2 so the rests are showing, the measure is copied perfectly.

Is this a bug or desired behaviour? I surely would like to be able to set the properties of the 2nd voice and have them copy along. If I have several of these measures I save a lot of time not having to set start/end voice properties for each and every measure.

I can replicate this scenario, but don’t know whether it’s a bug or desired behaviour. What you could do as a workaround is switch off your “start voice” and “end voice” stuff, do your copying and pasting, then select the whole passage, filter the second voice and go Edit>Remove rests. There may of course be additional information you’ve not given us that may make this workaround problematic for you.

Aha, so Edit>Remove rests actually “removes” the rests by adding the end/start of voice property, that’s good to know.
Next question would be: can the rest be “reappeared” by a similar command? If the only way is to manually changing the end/start voice properties, I am back at square one. At least when it comes to speed and effiency.

For my needs this is quite a problem. But maybe I just did not understand the concept.

The fastest way I can think of is by selecting the music, filtering notes, and disable the ‘end voice’ property. You can record this as a macro from the script menu if you need to do it many times.

Ok, one more thing that I never tried. So it is possible to disable end voice property on many notes at the same time…!
Thanks to both of you.

Tried a bit more and this seems to work under certain circumstances that I cannot really specify. In my particular case however it doesn’t work - I’ll try to post a file later. If it’s not me doing this the wrong way I would say this is a bug and a rather serious one.

I thiink probably best if you can demonstrate the problem in a posted (zipped) Dorico file.

The other thing worth considering is that there are various options for rests on the Voices tab in (I think) Notation Options. If it’s not there it’ll be in Layout Options or Engraving Options. You may find that you’re trying to do something manually that Dorico is designed to do automatically.

So, in the file there are two lines. The first one with the triplet on the second beat with “end voice” set on the third note, the second one with “start voice” and “end voice” set.

Try to copy to the empty bar. For me, the result is the same with R, ctl+c-ctl+v, or Alt+click.


shot.PNG
copytest.zip (264 KB)

I can reproduce the bug in a fresh file using ‘Remove rests’ and R.

I understand - bar 1 can be repeated exactly. Bar 3 can’t - the downstem notes start in the correct place but lose their triplet property.
Short of leaving the rests in place, doing your copying and pasting, then removing the rests, I don’t think there’s a solution.

Let’s hope somebody from the team chimes in sooner rather than later.

A similar situation was discussed here. The problem stems from selections not including hidden items. You can see this problem if you select bar 1 and then deselect the rest and do a copy to bar 2. The result is the same as copying bar 3 to 4 using a bar selection (where the rest is hidden).

Whether you agree with it or not, the decision to not include hidden items in selections is a design decision (some of the reasons are described in this thread).

Unfortunately, that approach leads to confusion as evidenced by this and the other two referenced threads.

Well, I see what you mean, but I did not hide anything. I just set the property of the first note of the downstem triplet to “voice start”, which I understand to be a design choice made to NOT being forced to hide things like in the other programs. I remember the thread you are referring to, I will read it again.

(Read the other thread again) Yes, that is really the same problem that I am having.
So you mean that in effect, Remove rests or using the Voice start/end properties are exactly the same?

Remove rests and using voice start/end are identical ways of doing the same thing. Remove rests is hiding the rest.

Hidden rest or not, the triplet does copy to the right position, but transforming itself into a non-triplet if the rest is hidden. That’s a bug to me… I have no problem with the design choice of selections not including hidden items. That is not the issue here.

I’d like to see hidden objects presented as dimmed or a different color in a selection. At least then we can decide if we want to keep them in the selection or not.

Imagine a text editor that didn’t copy tabs and line feeds unless they weren’t hidden. No one would buy that product.

This particular issue should be fixed with 1.2, give it a go!

Yes indeed!