Corrupted 10.5 Win10 update file

So, I decided to update my current version of Cubase so I got the 10.5. As the Steinberg Download Assistant hasn’t worked for the past 2 months (it doesn’t start at all), I dowloaded the update from the download section on Steinberg’s website. Upon installation I get the message that some files are corrupt and that I should download a fresh copy and try installing it again. I have done that several times but I get the same message. I also updated my e-licencer just to be safe. So, Steinberg people, how about some support? Why is that happening? Why the Assistant doesn’t work? BTW my system is fully updated with the latest version of Windows 10 64bit. I’m attaching a pic of the message I get on my screen.

Hope to get some advice as fast as I parted with my 89 AUD this morning.


This is user forum. If you want a support from Steinberg (you asked for in your post), rise a support ticket, please.

It doesn’t seem to be a generic issue, I haven’t seen any other report like this. So it seems something is wrong in your system. Maybe you can try to download the file on different system.

Thanks for your advice. There is nothing wrong with my system. The problem as I discovered today, is with the Australian download site. Their files are somehow problematic and that’s why the Assistant wouldn’t start at all either. I used a VPN and changed the download location to a different country, downloaded both the 10.5 update and the latest Download Assistant and everything worked just fine.

So, again if the Steinberg people see this, please check the files integrity on your Australian server.


I am experiencing the same issue, pretty annoying. Mr Jirsak, we could probably do without the attitude.

Also an Australian user - based in Melbourne - 10.5 update file not working for me either, have also had the same recent issue of the Download assistant no longer starting.


Get a VPN app, connect to a non Aussie IP address (eg UK, Germany), download both the Assistant and 10.5 update and you’re done.


Oh wow! Thank you for investigation and explanation.

Also in Australia, corrupt update and downloader not starting.

I don’t think having to jump through hoops with VPN etc is an acceptable answer.
I had to pay for the update, am I really expected to now pay for VPN access… :confused:
Steinberg, can you please fix your download???

or is anyone willing to be kind enough to upload working update file to dropbox and share a link. pretty please! :slight_smile:

Yup, I’m with you. You pay for something, you expect it to work properly. The funny thing is that the issue has been there for a couple of months I think. When I tried to update the Assistant manager about a month and a half ago, the app wouldn’t start at all. I thought that there was something wrong with Windows new update (1903) or my security settings. But all along it was the download location.

I don’t have Dropbox but I could send you the update file via WeTranfer in your email address later on tonight. Alternatively, look for some free VPN apps like Proton VPN or similar and download it from a different server.

Hi tc7four,
Thanks for the offer but I actually tried ‘Proton VPN’ that you suggested and that worked. and was free so all good.
Don’t get me started about windows 1903. My network would break after 10 minutes after every reboot. I’ve upgraded 1909 and it seems ok now.
Something about more QA testing needed for updates… cough. cough :wink:

Glad everything is ok :slight_smile:

Exactly the same issue. The Cubase Pro 10.5 download says the file is corrupted. I notice you poaid in AUD, as did I. Maybe it’s an Aussie download problem?


Would this help?