Corrupted Audio Every Start Up

So I spend a lot of time setting up. The studio workspaces have their interfaces networked with Lightpipe and wordclock; that means a lot of IO all over the place which had been fine until Cubase 12
The central IO is RME Fireface as it has abundant IO to manage everything even though I dont use a lot of the AD on it…although stll surprisingly good

What has been happening is that I set up. All is good, then I come back a week later etc and need to reboot. I go to open C12 and suddenly it only shows the Generic ASIO and no other devices (also occassionally use URC on separate USB for IO to external gear as the 32bit is quite usefull)

I then restart Cubase in safe mode, selecting Disable Prefs and it starts but I have to reselect routings etc

I have no trouble using Live on master daw with the same IO driver etc

C12 latest
W10 i7127k 32 gigs etc

If I restart using ‘Use Current’ it then says no valid license found
image

There were literally humdreds of DMP files so I cleared out before I started and it doesnt seem to have generated a new one
X:\USER\DAW\Documents\Steinberg\CrashDumps
The prefs etc are under a relocated docs folder not on C but this is common and allowed for W10 OS

Additionally I just ried using the generic and when I reopen, it has also lost the connection ie Control Room etc to this driver

A crash dump would help.

Use Microsoft ProcDump utility to generate a DMP file.

  1. Please download ProcDump64 from Microsoft (~650kB) and extract the archive to a local folder on your harddisk.
  2. Run Command Prompt (cmd) as administrator (right click and select “run as administrator”)
  3. Navigate (in the Command Prompt) to the folder with the extracted procdump file.
    For example:
    cd C:\ Users \ \ Downloads \ Procdump
    Note: the dmp file will be written into that folder.
  4. Launch Cubase. You can work as usual. At any time, change to the command prompt and start procdump, to monitor Cubase for unexpected behavior (see next step).
  5. Launch procdump64 via Command Prompt:
    Cubase 12:
    procdump64 -e -h -t Cubase12

The -h option will write a dmp file in case of an application hang. This might kick in too early sometimes, in case some action takes a little longer. Feel free to skip the “-h” option, if you are only up for fetching crashes.
The option -e will catch exeptions and the option -t terminations of the application.

  1. Prodump is now monitoring the Cubase process and will write a crash log, in case Cubase crashes or hangs. Perform the action that causes Cubase to crash and send us the generated crash dmp.

Share the DMP file

Thanks
Ok well ts not hanging/crashing as such…it just doesnt load the audio driver for RME unless I crash out and run in safe mode…but also loses the URC driver.

I tried running and came up with this (def admin and same msg if started after C12)
image

When I open in normal mode

If I open with disable prog prefs

As well as none of the midi is getting through to generic remotes etc…its showing up in Midiox fine

EDIT: You gave me a typo! the -t needed a space. …here is the dump file

DMP

But the command I posted has a space before and after -t

Anyway,

There was an access violation and its cause is unclear from the WinDbg analysis. The exception code C0000005 suggests that the program attempted to read from or write to a memory location that it didn’t have permission to access. The memory address 00007ffb239c63b0 was non-executable, leading to the access violation. The failure bucket ID and hash don’t provide any diagnostic information.

To further diagnose and resolve this issue, you may need to talk with someone more experienced. That’s all I can understand.

Do you have the latest drivers running for the RME?
Have you tried uninstalling and re-installing them?
Windows latest updates installed?

Sorry my fault…I read no space on my screen…

Yes definitely.
Issue is…it didnt happen with C11

Ok, since this happens when deleting preferences, try the following:
go to %appData% Steinberg/Cubase 12_64 and zip the entire Cubase 12_64 so you have a safe copy. Then delete the folder.
If you have other installations of Cubase 11 or so do the same for these.
Then start the program to see if it’s fixed

Yeah I remember I tried that previously…forgot the outcome but will try it again…on holidays atm…when Im back in the studio…I only take Live on my laptop for inspiration recording (and an nt4 for guitar/vox that can actually be used later

1 Like

Be careful, not to corrupt a project when the audio driver becomes dysfunctional since, while it is unlikely you will lose data, the project can no longer be saved and therefore you will need to import tracks into a new project or copy/paste objects from the previous file.

Cheers
Got back from urlaub yesterday…Ok I did that…fixed it.
BUT
Now I remember what happened last time;
I have a number of interfaces networked in diff parts of the studio and they all flow back to this daw via RME. That means there was a lot of work done on the IO presets…a lot of work.
Last time I wanted to simply copy paste sections of all that work because before I got it all into order the same corruption of IO occurred before I got to transfer the setttings as I wasnt goint to repeat the same mistalke
I remember asking on the forum for a spreadsheet/matrix highlighting where everything lives in prefs as its a mine field of siltation and no answer was offered that was straight forward. Of course you lose all the other settings as well so I guess Im back to the same maze now

So I gave up on cubase for a while and been using Live
BUT
I would like to use what I paid for

So the driver no longer corrupted but all my presets, plugin lists, control room presets etc has disappeared

I AM NOT prepared to redo them all AGAIN

Surely someone must know who to recover them?
PLlease???

Instead of new features/13…would be great if some of the housekeeping stuff was fixed…brought into the 21st century…still the same as SX and VST 32 it would seem

Yeah sorry, its just getting ridiculous

Have a further step to check possibly corrupted files in the system:
Use “sfc /scannow” as administrator in the command prompt.

Thanks @Puli I will try that…
but
my simple question is where do all those presets live, so I can copy them into the current ‘new’ non corrupted settings without having to redo them all…again…and again…and again :slight_smile:

If you mean Cubase presets and preferences they are here:
%appdata%/Steinberg/Cubase X_64
and have a further look here:
C:\Program Files\Steinberg\Cubase X\Presets
C:\Users"yourname"\Documents\Steinberg\Cubase\User Presets

Sorry if I wasnt exactly clear
I know where the files live…I have backed that folder up
but are you saying all the IO configurations presets live in the “ControlRoom” presets?

What actually happened last time (I think) was that I did all this, copied the control room to get all my IO back and then it simply corrupted.

I apologise but Im just so frustrated…this has worked find since 2005…and not just these random corruptions’

EDIT:
I imported the control room and the routing came back but what about all the midi control surfaces etc? They are all missing as well?

They might be here:
Documents\Steinberg\Cubase\MIDI Remote\User Settings

Thanks but this is what I mean…trying to chase and work out where stuff is. This location is for the new control surfaces
The active device connections is part of studio setup, part of control room etc. If audio IO is in that xml then why is midi not? and where actually is it?

There should be 4 devices here with all sorts of routing…generic device is the only way to reasonably access all the midi control that I use…control surfaces in no way can replace the programatic functionality in its present graphic form of control surfaces…its not ableton…which can easily do it via python.

External FX and external instruments were also missing from the controlroom.xml

And all my shortcuts and macros are missing as well?

I never use control room but if I had such of trouble I’d try to save as template. Did you try it or the issue happens everytime you open a saved project? Shortcuts and macros should be saved as well, mines always there since their creation over and over the Cubase upgrades.
Plus you can save your profile and name it, all those preferences and settings will be saved.

Control Room is amazing…!
This only happened when I upgraded to c12. I have been using Cubase since atari v1.0
But this is what I mean, there should be a simple utility to reset particular preferences and/or clearly named prefs files that contain each section.
Im pretty sure templates dont save everything…I think I tried that way back in the start. Templates are a whole as well so you cant just update a live project. That leaves the shortcuts etc to Profiles which dont export/import singularly (that I could see)
The audio driver corruption happens randomly and affects everything else.

These issues are all related to persistent preferences held in the User Profile…not within the project itself