Corrupted project ? Opening fails

Good afternoon everyone,
I’ve encountered a bug with Cubase 8 for about a week now. One of my project seems corrupted. I can not open it, it gets stuck on the small loading window, and it always block when loading the same tracks. After a minute blocked on this screen, cubase crashes. I’ve tried getting my project back from one of the .bak files, but I had the same bug.
Fortunately, I am also using Time Machine so I was able to recover a working version of the project. It opened correctly etc, and I didn’t have any problem working on it. But then, when I tried to open it on the next day : same issue !
Has anyone had the same issue ? Does anyone know how to solve it ? Thanks in advance for your help.
Config : Mac OS X Yosemite, latest updates

Edit : I think I’ve now found (pretty much) the source of the problem : when I open the working version of the project, and merge some regions on a track using the Geist VST, I’m not able to open it again. I tried exporting those tracks, then deleting them, and replacing them with the exported audio, now the project seems to work. I’m not sure about it though, I’ll have to test again to be sure.
Does anyone know where this might come from, how to avoid it, etc ?


This problem happened again, on another project. On this one, everytime I edit something from one of my percussion (=audio) channels, I can’t open the project anymore. Any idea where this might come from ?