could not open key UNKNOWN/components


I am trying install the Cubase 6.0.5 update - never had this issue before but am getting “could not open key unknown/components” followed by a trillion digit number - error message about permissions? I have tried the installation in both administrator and non-administrator modes, and also opening the upgrade exe file in administrator mode, but no luck.

There are google references to this and various permissions fixes which have not worked

Has anyone else had this problem and found a workaround?


I think you will get more of a handle on what’s up if you google: “could not open key unknown/components”

From a quick look I surmise that you would be very lucky if anyone here could fix it or diagnose it quickly.
Seems to be a registry problem of sorts.
Try a defrag first, if you’re lucky that may be all needs doing but you could have data corruption or bad sectors interfering with installation.


thanks for quick answer, much appreciated. As I said, I have googled and tried various ‘fixes’, nothing has changed on my PC and previous upgrades have worked fine.

I will try the defrag option and do a chkdisk.


Ah! I wasn’t sure what you’d looked at. When I get things like this happening I generally study two or three of the sites and try to get an overall picture of what it might be and then give my system a good going over.

I’m thinking that you might have to uninstall Cubase, clean the registry of all Cubase pointers then reinstall Cubase and then apply the 6.0.5 update.