Count-in during playback

Cubase 9.5.20 running on Windows 7
Is there a way to have Count-in during playback?

I know where the Count-in button is at the bottom of main project window next to the metronome activation and metronome settings buttons.
Count-in when recording works, but it does not if only play is selected.

Moreover Pre-roll on the Transport menu is no properly following the Activate Count-in at the bottom of the main project window.
If I select Pre-roll (and it has a check mark next to it) I do not get Count-in bars when I press record.
And if “Activate Count-in” was previously selected and looks now white, when selecting Pre-roll in Transport Menu it is deactivated and goes back to gray???
If I only select Activate Count-in and forget about Pre-roll (no check mark on Transport Menu) Count-in works for recording.
Whether I activate Punch-in or not makes no difference to the Count-in or Pre-roll behavior in play or record.

Is playback Count-in a limitation in Cubase or is there something else that has to be done for Count-in to work during playback.

It is a necessary option for rehearsal and it seems silly to have to move the hole project a few bars back just to set up manually a few bars for count-in.

Thanks

Bump… I need this and use this feature of most DAWs as well for rehearsal - it should be called ‘rehearsal count-in’ … but i can’t get Cubase 11 Pro to do it either. count-in seems to work only in Record mode… Steinberg?