.cpr still opens in C9.5

Hello all,
I got a little anoying problem, but I gess it’s more a windows problem. In windows 10, when I double click on a .cpr file, it starts with C9.5. The strange thing is that even if I righclick, go to “open with” then go to C10, it still opens in C9.5. That’s odd. No big deal, I open first C10 with the desktop shortcut (that works) then open my project, but I would like to solve that issue. Any idea ?

I ran into that problem, too. Here is an “Issues” thread with more info
https://www.steinberg.net/forums/viewtopic.php?f=286&t=148007

What I find strange is that when I watch witch version the .cpr is opened with, either with the file explorer or the control panel, it tells me “Cubase 10” but still opens it with 9.5.

Just select cubase 10 as default program for .cpr files

:laughing: Thanks 01w. If you read the posts, you may realise that is what I do.

There was a recent Windows update that caused problems with file associations. More info here.

You can either wait until Microsoft issues a fix or use the PowerShell script here (at your own risk).

Just noticed that this is my 1st post after joining almost 8 years ago. How’s that for lurking? :mrgreen:

Oops sorry.
Try rename the fodler where your older cubase is in, or move ir to another folder so windows wont be able to find it by default when opening .cpr project

Thanks for the info, I think I’ll just wait for an update. And sorry that I made you come out of the woods. :mrgreen:

Here is what I got. But double click opens C9.5…

Here is an answer I got on Microsoft forum :

Setting File Associations in Windows 10 is now impossible, a lot of users are reporting this at the moment, this seems to be a bug in Windows 10 since the last update.

Microsoft are working hard to patch the bugs in the last couple of updates, hopefully this is one of the bugs they are working on

Please provide feedback to the Windows Developers on this bug, press Windows Key + F to open the Feedback Hub, the more users that report this, the quicker it will be resolved . . .

The problem is not only in windows 10. I have windows 7 and I have the same issue.

Yes, it’s crazy : I tried to change the name of both folder and .exe of C9.5 and when I open a .cpr, windows starts to install C9.5. Hopefully Microsoft will provive a fix for this.

Fixed it:
Two things that are a must to fix issues related with older versions of Cubase Pro.

  1. Go to the following WINDOWS folder
    C:\Users\YOURNAME\AppData\Roaming\Steinberg
    You can also get to this by In the command line of the ‘Run’ window, enter this path: %appdata%/Steinberg
    You should see all previous versions of Cubase Pro. If not make sure you un-hide hidden folders.
    Rename previous Cubase folder versions by putting an ‘x’ in front of the folder.
    Example;
    Change the folder “Cubase 9_64” to “xCubase 9_64”

  2. Right click on any existing .cpr file and select open with…
    Select choose another app…
    Navigate to the Cubase 10 program installation which is found in…
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Steinberg Cubase 10
    Remember to tick 'Always use this app to open .cpr files"

Done and fixed!

There is nothing done here which cannot be undone and requires no registry deletions.

Baycider