CPU Overload during export, but only with particular tempo changes

Hi all,

I’m a new user to Cubase 12 pro. I’m currently producing a project that is all VSTs, and my system specs are at the bottom. The central instrument here is piano, and I recorded it myself as MIDI and am playing it back through my VST. There is one part of the track where there is a ritardando from 65 bpm to 55 bpm over two bars, then 5 bars of 55, followed by a snap back to 65. I had recorded in the piano MIDI, used Time Warp to mark out the ritardando over the two bars by setting the downbeats appropriately. Here’s the issue: with that Time Warp in place, if I play the project back in Cubase from the start, there is a small skip in the audio at the start of the ritardando, and if I try to export, it gives me a CPU overload error exactly when it reaches that point. If I play back from close to that point (5-8 bars before), there’s no problem. I deleted the time warps, and it exports just fine, but without the tempo change. I then tried putting the tempo changes into the tempo map, but without time warp, and now it has the exact same issue at the change back to 65, not 55. I’m also a bit confused by the fact that, even after deleting the time warps, all of my MIDI events are still organized in the proper bars. Does anyone know how to help with this? I would greatly appreciate it.

This version, with the tempo change at bar 40, causes the CPU overload during export.

This version, without tempo change, does not cause the issue.

Windows 10
AMD Ryzen 3600
8 TB total storage (2x 2TB SSD, 2x2TB HDD. Project, Cubase, and all VSTs stored on an SSD)
Universal Audio Volt 276 Audio Interface

Is the piano you are using by any chance a Kontakt instrument that uses the “replika” delay, particularly Noire (which instantiates a replika instance at load time, whether you use it or not)? That’s been a bug for a while. The only known workaround I know of anyway is in Kontakt, go to the header area and turn off tempo sync.

Thank you so much, that was exactly the problem! I’m using the Kontakt Le Grandeur piano, and turning off tempo sync in Kontakt completely fixed the issue. I so appreciate your help, thank you!