CPU & Performance issues CUBASE 11 (Catalina, i9, 64go ram)

Hi,

First of all, I apologize for my english, I may do some writing mistakes.

I’m dealing with serious issues for month with Cubase on my MacBook pro 16 (Catalina, i9 2,4 Ghz, 64 Go Ram, 4to ssd).
I’m a professional music producer and I use Cubase 11.0.20 literally everyday through different session of recording, composing or mixing. I was in a music session yesterday when my computer starts to going crazy. Barely 15 tracks were armed. I even had to cancel my session because I could not even keep working. I think it’s time to me to expose my problem.

For maybe 3 years, I constantly got some CPU issues. When I check the activity monitor, Cubase goes (for a normal session) from 300% to over 1000% of CPU usage…! The Audio performance inside cubase always peaking, sometimes on average load, sometime on real-time peak. I often got “Recording error: audio drop out detected.” message when I record, preventing me to go ahead in my recording session for example. The problem getting worse since a few weeks, I can even go until the recording step, I’m always peaking just by loading some vsts or audio tracks.

Here’s everything I’ve made:

  • I changed my Macbook Pro almost 1 year ago, the previous one always had a lot of audio drop out, but I feel like it was mostly because of his performance (i7, 16go ram).
  • I installed every update of Cubase hoping the situation will get more stable, in vain.
  • Increase my buffer size
  • Set the Asio guard to low, medium, high
  • Turn on/off multi processing
  • Boost Audio priority
  • Change the processing precision

I also tried to:

  • Disable Hyperthreading
  • Reset PRAM/NVRAM
  • Reset SMC
  • Reinstall Cubase (11, 10)
  • Turbo boost switcher

Honetly, I’m totally desesperate. I feel like I’ve check every topic on every forum on the internet, tried everything but the problem still goes.
The problem can be Cubase, or my Macbook pro, but I can’t tell…

I do not own a mac, I cannot help you directly, but this peaking disk activity in picture no. 2 really grabbed my interest, especially since you have an SSD. I have never seen such high disk activity for such a modest track count, and my systems are considerably weaker.

Are you sure the project sits on your ssd and hasn’t wandered off to cloud (dropbox etc.)?

I’m running on a Macbook Pro i7 16gb ram on macOS 10.14.6 Mojave and never run into any issues. It could be Catalina causing the problem, not sure if possible to downgrade to Mojave. I’m looking through your post but I don’t see the audio interface you are using. I’m using an Apogee Ensemble Thunderbolt and never have an issue. Make sure your audio files are going to a separate drive directly connected to your computer port. Turn off the internet while recording, Make sure you have any virus software disabled. Maybe get a cleaner program like MacCleaner Pro. Back up your system drive with SuperDuper as that will make any reinstall easier. Much better than Time Machine.

Hope this helps.

Yes, all my projects and samples are played from my internal SSD

Hey Gary, thank you for your response.

My audio interface at home is a RME babyface pro, but I use to connect every kind of Apollo at studios.
You’re right for the wifi, I use to disable it while recording tho.
I don’t have any anti virus on my Macbook.
I had maccleaner but uninstalled it last week to see if this was the problem.

Hi, I know I had trouble with Catalina and there is a know bug in 10.15.7 version that I saw online. I am running Cubase 11.0.0 because 11.0.20 was having issues of finding the license. In computers “anything can cause anything”. I would really start by going back to 10.14.6 or up to Big Sur. Reinstall the RME driver. Uninstall any unneeded software. I could be something with your computer too. I had a logic board go bad on my laptop and had to have it replaced which was an expense repair. Good luck. Sometimes starting fresh is the best way to go with starting with a clean install.

I had the same issues on Mac OS and Cubase 10.5

One thing I don’t see in this post is what sample rate and bit depth are you recording in? I mostly record in 48k/24bit. If your recording higher I would try to go down to 48K or 44.1k. These days most stuff gets compressed to mp3 anyway. I’ll record in 48k/24bit and mix in that too. Sample rate I’ll leave to a mastering engineer.

From the screenshots, I think it’s 44.1K/24bits, and that’s what even more perplexing.

I still believe that a cloud service is trying to upload project files to the cloud and hogging the disk. Disk usage is out of this world.

I record the most of my session in 44.1khz/24bits.

I’ve tried to upgrade to Big Sur to make some tests before a clean install of my macbook I’ll make this week end.

I’ve discovered something yesterday.
While I was working on a song, the audio performance meter starts once again to go crazy. I quickly opened the monitor activity and it looks like the problem came from “kernel_task” who peaked at 600% CPU. I read a few thing on some forums about this kernel task, this looks like a processus to cool down the cpu.

But the question is, does the problem really come from kernel task or from Cubase ? My laptop overheating constantly…

I also noticed that some VST (legits) like Repro or Serum was eating my CPU just by loading it once. Well, for an i9, 64go ram, it’s kinda annoying…

Plugins can take a lot out of the laptop. You might think about getting UAD plugins as they have external processing cards and takes all the load off of your main computer. I very seldom us native plugins. UAD has some great sounding plugins and you can have up to 4 external processing cards working .

I wonder about trying a laptop cooling pad? In my country they’re fairly cheap from Amazon and are bus powered.

You have a very powerful laptop, it is strange that it would choke up on so few tracks.

Hi,

Some updates of my situation.

After my issues appearing 2 month ago, I decided to bring back my Macbook to an Apple Store. They made all the hardware tests but nothing seemed to be abnormal. They cleaned it outside (fans) and inside the box (malwares, etc). When they bring it back to me, after 2 hours of use, my performance peaking issues inside Cubase came back. I was so annoyed…

A friend told me some slowdowns may come from my USB type C Hub, I was amazed to learn that USB C Hub got firmwares included in the box. I’ve decided to buy an official Apple Hub. I’m getting so paranoid.

Also, I’ve decided to, once again, clean install my Macbook. I upgraded a fews days before to Big Sur but went back to Catalina.
During my installation, I meticulously install each software and third party plugins with legit installers, also keep the SIP ON (I disabled it on my previous installations, that’s why I may had some serious malwares).

Surprise, until today, everything worked like a charm. I went back to studio, and no freeze or performance issues avoided me to work on, sometimes, huge sessions.

BUT, and here the reason of my return on the forum, yesterday, while I was working on a project (that was really minimalistic) the CPU performance issue came back. Impossible for me to keep working, the session keep freezing after 5 seconds of playback. I thought about it, it was really hot that day, so maybe it was due to the temperature of the room… Nevermind, I wasn’t that surprised.

Today, same scenario, but with a really temperate room !! Here is a screenshot of my session, barely 10 tracks opened though…

If the issue obviously doesn’t come from my Macbook, it is oubviously a software or Cubase issue, right?
I’m honestly so annoyed… what the hell can I do now ? I feel like my whole economy will fall down, I can’t work anymore.

Anyone ?

@BlckDoe ,
I’m stumped.
Did you try loading a recent project that was behaving properly? See if it’s still good?

If you did that, and you determined that something in this new minimal project is the culprit, my troubleshooting process would be to:

  • Duplicate the project file as a backup.
  • On the duplicated project, start eliminating one track at a time, first by erasing the track contents then deleting the track completely until you notice the performance change or until the project is an empty slate. Including groups, FX, inserts on the master buss, instruments etc.

Hope you sort this out.
Please follow up either way.

PS: I notice you have some some tracks with nothing on them. Get rid of them and any other dormant tracks that might have been part of a template FIRST.
Then start shaving your project.

It’s likely a third party plugin that isn’t sitting well with cubase. Follow the steps given by the previous poster. I’ve found some VST 3 plugins don’T work well sometimes but if you replace them with VST2 then it usually fixes it.

I’m running cubase pro 11 on a Mac Pro. No issues. Rock solid and stable.

I’m on PC so this may not be helpful, BUT - on my PC I find that Steinberg does not like VSTi… which I find really odd because Steiny is all about MIDI. For example, if I have even 6 tracks and 3 of them are VSTi, even if I’m not recording with them at the time BUT THERE ARE RECORDED MIDI TRACKS PLAYING BACK, my CPU usage can get into the 50% range with only 3 instrument loaded. If I render the MIDI tracks into audio and remove the VSTi, my CPU usage drops to 8%.

What I would suggest to the OP (Original Poster) is to copy the project, open it, and remove the VSTi from their channels and see what happens. Of course none of this makes any sense to me considering the praise Steiny gets for it’s MIDI implementation. If anybody here has a suggestion of what I am doing wrong, please don’t hesitate to offer some help.

I am having similar performance issues that weren’t there before. Last night I had 1 stereo track and 5 mono tracks and no VSTi, but still I kept on getting the audio drop out warning. I ran a memory clean software that fixed the problem temporarily, but I’m sure it’ll come back. I have an i7 with 32 GB ram and 3 TB Fusion Drive.

Did anyone ever figure this out? I am having the same EXACT issue…

Yes, same issue here. i9, 32GB RAM, 1TB SSD MacBook pro 2019 and I couldn’t work with Cubase due to this nightmare of a problem. I will give you the following 3 advice that have sold the problem for me.

  1. NEVER upgrade Cubase. Always uninstall the old version, download the complete new version and install it.
  2. ALWAYS use Apple certified USB hubs.
  3. Never put the Interface and the charger on the same side or in the same hub.

Hope that helps!