cpu spikes and popping audio when using ASIO

Dont know if this should be somewhere else but just giving you guys a heads up to resolve a problem that took 2 days to find.

Brand new computer build i7 6800k asus a2 x99 32gig ram

Turned off ‘Turbo boost’ in bios and everything works like a dream.

is this a cubase issue or something else?

That is an old classic windows real time audio thing.

If you google windows real time audio. You will find a whole bunsh of info on the subject.

http://www.resplendence.com/latencymon you can use this program to quickly find what tweaks you need to do.

I have bin on daws for 20 years. Can’t say there have bin much improvment in windows and audio. :laughing:

Windows should take the time and make a built in real time audio app. Wich tuned the hardware to be in sync with the real time audio engine.

As off now you need to use 3 party programs or have the “know how” to get the most out off the daw.

I have seen so many fustrated people over the years. Blaming the audio driver or the daw for all the pops and crackles. When truth is that it is the onboard hardware and windows that is not playing along.

Have you tried to adjust the buffers ?

what sound card do you use ?

Just my two cents worth…

Computers come out of the box in save-the-planet mode. This is, of course, a Good Thing but not when it comes to real-time audio.

According to your BIOS, there are probably other things you can adjust too. Here are the BIOS settings that work for me: C-State OFF, SpeedStep ON, TurboBoost OFF. You may also benefit from having Hyper-Threading OFF (or ON…).

Windows comes into it in the shape of Power Plans, which allow throttling of CPU, USB and PCI Express. The Steinberg Audio Power (SAP) option in Device Setup forces the CPU to 100% by creating a temporary power plan. This is essential but if you want to bring in the rest you’ll have to create your own and switch to it after you launch Cubase (or not use SAP). See this thread for more: https://www.steinberg.net/forums/viewtopic.php?f=228&t=97747