CPU Spikes calm down if you enable/disable PDC

Could anybody confirm?
When the CPU gets too busy, enabling and then disabling PDC
calms down the CPU usage from 70% to 20%. Spikes stop immediately,
at least for a while.

Buffers 512, ASIO guard on, and Normal.

EDIT: this is way simpler and faster than having to go to ASIO
settings and changing buffers, just to reset the spikes on COU usage.

We had masses of cpu spikes. Since we updated to window 10 and Nuendo 10.
Trial and error led us to de activating “Multi Processing” in VST audio setup.
The difference is night and day, we can (if we choose) run at the lowest buffer. But no sense in putting unnecessary strain on the PC.

We were under the impression that “Multi processing” spread the load across all CPU’s https://steinberg.help/cubase_ai_le_elements/v9/en/cubase_nuendo/topics/optimizing/multi_processing_c.html.
Could this be a N10 bug. And is displaying incorrectly.

We were a long time still on Win10 1809.
Finally I found the time to update Win10 to 2004 at the moment and that actually solved ALL our CPU Spike Problems.
On simple Projects I could not go lower as a 1024 Buffersize. Now 128 or even 64 is no problem at all.

So… Win10 Updates actually do stuff :wink:

Yes but my question remains.

What do you mean by PDC ?

PDC stands for Parameter Delay Compensation, the second Icon on the top left of your Project Window.

Please try disabling (light goes on) and then enabling (light goes off, I know it’s counter intuitive)
and see if your CPU usage and spikes decrease.

Mine does, by a lot. If I am at 70% CPU usage or so, it will decrease to 20%.
I used to increase the buffer size on my audio card, or re- adjust ASIO Guard,
but now this is what I do with the same result, and simpler and faster to access.

I am trying to find out if it is just my system, or if you guys get the same result.

You mean to constrain the delay compensation? That will disable all plugins that are not zero latency!
That means you disable most of your plugins in your session which of course will reduce CPU usage!
In the end, that has nothing to do with anything that might be broken or not working in nuendo.

Take a look at your mixer while clicking on that icon… :wink:

Best

Basicx

He meant first enable and then disable constrain delay compensation! I guess thar redistrubetes the processes/threads.

Oh, my bad! Will check that!
But that would me to simply reload the Mixer :wink:

let me check

lg

Exactly.

No need to school me on what it does since I use Cubase and Nuendo since version 1,
and I also use to give seminars on Nuendo.
The question is if you toggle it (disable/able) you get the quickest CPU spike and usage recover.
In my system it does, but I’m mentioning it because not all systems behave exactly the same.

Nothing like that happens on my system. Running RME MADI and I don’t get spikes. Toggling the Constrain PDC button makes no difference here.

There was an issue that I investegated years ago, with dawbench, that afther loading the system to the edge, saving and reopening that session would send the sytem over the edge, because opening and adding did not give the same load. I am wondering now if this trick would have helped, if I remember correctly changing buffersize did. BTW also on RME here. This was only noticable when you run your system under very heavy load.

Exactly, it only happens if you lower the buffer size to record MIDI, for example,
and there are many active plugins. I no longer need to change the buffer to calm down the CPU,
I just toggle ON/OFF the Delay Compensation button.

Needless to say that the buffer size eventually has to go up as the project gets larger and the number
of plugins increases, but by then most of my MIDI is already recorded, so it no longer is an issue.