CPU Spikes in Cubase 9

I know this is a topic that has shown up in a few other posts, but I’m noticing sudden big spikes that now make using Cubase impossible. I’m using Windows 10 home, a Focusrite 18i8, Intel Core i7-4790, and 24GB of memory.

I’ve run latency Mon and it said everything looked OK. My e license dongle is in a USB 2.0 port.

When I open a new session in Cubase 9, without even creating an audio track, I hit F12 to see the CPU meter and I’m getting spikes every 5-7 seconds.

I’m pulling my hair out because of course this started happening when I just started to do scoring work. Any help is much appreciated.

Hi there,

Is this a new issue for you?

Did you run the same configuration to do with your Virtual Instruments and Plugins and worked fine in the past?

I had the same issue. For me it was because my computer (I also had a PC with an i7 and 24 Giga RAM) couldn’t run the libraries I was running. Cubase freaks out if you load too much stuff. There are other problems with Cubase though. I found that sessions would get slower the more I worked on them.

Has windows recently updated itself

Yes, Windows updated recently. I’ve since uninstalled it. I also updated to Cubase 9.0.40. The problem remains.

Thanks, somecomposer. Everything used to work just fine. I recently updated some Vsts (the new version of Arturia Pigments for instance), but even without running any of them I’m getting big spikes. Playback on a session with three or four audio tracks becomes crackly.

Have you checked the power plan or are you using steinberg power plan. Updates can default windows tweaks which may stay even when you roll back.

1 Like

I see…

As another person mentioned here, look at the power plan on Cubase. Set it to maximum to help Cubase deal with all the management.

Failing that, try to uninstall the latest plugins. If the issue remains, best thing is to reinstall Windows.

Start from scratch and by a method of elimination, find what the offending plugin is.

I had an issue lately, with a new computer and the old version of Spaces was crashing windows to an unrecoverable point. I had to do the same and find out what the issue was.

It could be anything, start from the bottom up.