CPU usage higher under v1.1.2

A project started under v1.1.1 now has much higher CPU usage under v1.1.2 - I have used preload.

My desktop is on a AMD Ryzen 9 5950X 16-Core 3.40 GHz processor (128GB RAM).

My laptop shows lower CPU usage on the same project - it is on an Intel Core i7 -8650U 1.90 GHz processor (16GB RAM).

The desktop is using a Yamaha N8 firewire audio input - whilst the laptop is using the onboard soundcard.

How does VST Live work with multicore processors?

We need way more information, which plugins, how many Layers, do you use Stacks, MIDI Tracks etc. You may send a .vlprj file for us to examine, thanks.

Project shared in private message.

Thank you for your help.

It’s good to see v1.1.3 - the record next song end action, and the zoom on Cubase import fix are great, thanks.

The CPU usage issue here is related to preloaded layers not clearing when completed - you’ve said. You mentioned this will be addressed in an upcoming version. Is this slated for the next release?

Many thanks

We had an issue with Stacks not clearing which we fixed.
What problems do you still encounter?

Still getting CPU maxed out when I activate preload, but it’s fine when I don’t preload.

It should not make a difference. Only the actual Song and Part (plus Global Part) should ever be active (plug Master Channel and its inserts). Also activating one Part after the other should provide the same result as preload.

On the project I’ve previously shared thru PM - the project runs ok without preload, but the CPU maxs out if I run preload.

Ok, will check!

1 Like

Hello, I still have the problem with the preload in the staks. Loading the project activates all song staks, but does not deactivate them. Which causes a huge jump in CPU usage. Then, I manually go through each of the parts of each of the songs, and the consumption is gradually deactivated, until it remains in normal CPU use. Only then can I run the project.
Version 1.1.30.645. macOS Big Sur Intel.
Sorry for my English, I use Google translate.

Hola, sigo con el problema con la precarga en los staks. Al cargar el proyecto, se activan tosos los staks de las canciones, pero no se desactivan. Lo cual provoca un gran salto del uso de CPU. Luego, manualmente paso por cada una de las partes de cada una de las canciones, y se desactiva el consumo paulatinamente, hasta quedar en uso de CPU normal. Recien ahí piedo correr el proyecto.
Versión 1.1.30.645. macOs Big Sur Intel.
Perdón por mi inglés, uso el traductor de Google.

There is an issue, still trying to figure it out. But it appears to be related to the Global Part. I removed that, saved and reloaded the project and the problem seems to have disappeared.

@ Cucuso, are you running a Global Part, and if so, do you have one or more Stacks in there?
Will get back when we know more.

It is related to the preload function, as you already pointed out.
For now, you will have to disable “Always Preload” in File/Preload…, sorry. Will fix asap.

1 Like

I am not running global part.

Right, sorry.
We found two cases where Stacks refuse to unload:
a) with the preload function
b) if you go from a Song - say, Song 1 - to the Global Part, and then from there to a different Song than before (say, Song 2), then Stacks of Song 1 stay active. For now, try to avoid both scenarios. If you really need preload for fast switching of Parts, you may select each part with Stacks once - tedious, but it should work. Sorry for that, will fix asap.

2 Likes