CPU usage when nothing happening?

Hi

I have a project loaded in Cubase 5.5.3, I haven’t touched anything for the past 30 mins and Cubase is using 65% cpu. Is this to be expected? My machine specs are…

Mac OS X 10.6.8
3.06 Intel Core 2
8Gb DDR3

The project is using a video track, and several VST’s…

Ivory
Battery 3
Halion Orchestra
Kore 2 with 7 Kontact VST’s loaded
Kore 2 with 3 Kontact VST’s loaded

Memory usage is sitting at 2.10 GB

Looking at the stats for the process there are about 10000 context switches per second.

Any help would be appreciated.

Out of curiosity I created an empty project, and the cpu is sitting at 10%. I’d be interested if anyone else has this?

Cubase 32 or 64 bit? In what bit environment?

I’m using Cubase 32 bit. Mac OS Snow Leopard is 64 bit, but under my system overview it says…

Kernel Version: Darwin 10.8.0
64-bit Kernel and Extensions: No

…whatever that means?

Just came across this, I just assumed 64 bit mode would be enabled by default…

Quoted from http://en.wikipedia.org/wiki/Mac_OS_X_Snow_Leopard#64-bit_architecture:

“In addition, the Mac OS X kernel has been rebuilt to run in 64-bit mode on some machines. On those machines, Snow Leopard supports up to 16 terabytes of RAM. Newer Xserve and Mac Pro machines will run a 64-bit kernel by default; newer iMac and MacBook Pro machines can run a 64-bit kernel, but will not do so by default.[29] Users wishing to use the 64-bit kernel on those machines must hold down the numbers 6 and 4 on the keyboard while booting to get the 64-bit kernel to load.[30][31] A change to the com.apple.Boot.plist will also enable users with compatible computers to permanently boot into 64-bit for those wishing to do so.”

If you’re using CB 32 bit in a 64 bit environment, you could be experiencing a bridge problem. The vst’s you’re using may not be fully compatible with CB’s bit bridge. That very well could lead to excess cpu and/or ram usage.

I just tried out enabling 64 mode and I still see the same cpu usage. However you are right about some software not being compatible, my Yamaha Steinberg FW failed to start.

I guess the most useful thing would be to see if anyone else is experiencing the same problem. That way I can isolate whether it’s only my setup.

WOW: You guys amaze me with the fact that I could witch my OS to 64bit…
Can anybody indicate me whether I must reinstall Cubase and/or plugins in 64bit versions if I start OSX with 64bit mode?
Until now I noticed, that startup is slower. Has it any effective disadvantage to run in 64bit?

Concerning this specific question:
a 100% reproduction of the case normally is impossible.

Thus some other questions:
Do you use some older plugins which perhaps use the VST-Bridge? The VST bridge normally consumes pretty much CPU…
Aditionally: a certain CPU amount is off course due to the VSTi’s loaded… There are some VSTis which are even in “standby” pretty CPU consuming…

My recomendation: Deactivate one line after the other by freezing the instrument and unloading the VSTi, or if you loaded them as VST-Instruments, by deactivating them temporarily…

Hope that helps you to analyze which Instrument or which insert effect is consuming so much CPU in your case…
Instead of reproduction of the glitch: try to find the component which causes the CPU-usage…

You should have the 64 bit version of CB on your install disc. You don’t have to uninstall CB 32 bit, they can both exist simultaneously on your 'puter.
There should be no disadvantages running your 64 bit environment unless you have programs, apps or vst’s that only run in 32 bits. The advantage of running CB 64 in a 64 bit environment is having full utilization of all your ram.
If you’re not experiencing smooth performance, many concede to CB 32 bit in the 64 bit environment.
CB’s bit bridge will allow many 32 bit vsts/effects to run in CB 64 bit. Some may not reach their full performance as the bit bridge is not perfected. Jbridge is the alternative and has proven to run most 32 bit plugs and is continually updating it’s compatibility. It will also allot 2G of ram per plug when running CB 32 bit in either environment.

THX!!! Got some things clear now…

But when googling I remembered something which I got reminded of in this thread:
http://www.steinberg.net/forum/viewtopic.php?p=9740
Cubase 5 is not available on 64bits for Mac OSX… just for windows…
Cubase has 64bit support on OSX from version 6 on…

bad luck :wink:

Yep, only Cubase 5 32 bit for Mac OS, although it’s relatively cheap to upgrade to Cubase 6.

Jbridge is the alternative and has proven to run most 32 bit plugs and is continually updating it’s compatibility. It will also allot 2G of ram per plug when running CB 32 bit in either environment.

I’ll have to check Jbridge out, although I thought Cubase and it’s plugins would all run under the same process, in which case everything would be limited to 32 bit memory addressing?

Yup, Jbridge uses inter process communication between 32 and 64 processes. Unfortunately it’s not for Mac OS though :cry:

Anyone else been able to replicate the cpu usage problem I’m experiencing? It would be really helpful to me as my machine is short enough on resources as it is. Just create a new project and look at the Cubase cpu usage when nothing is happening.

OK… partly reproduced…

  1. The CPU indicated in Cubase is namely not your own CPU but the ASIO CPU usage

  2. an empty project with no instrument or MIDI track gives nearly no CPU usage…

  3. my own default project with several VSTi’s (CUbase & 3rd) gives a default ASIO usage of 35%, just after loading.

Explanation: As mentioned before, every loaded Instrument and Insert Effect once loaded, creates an ASIO usage. Don’t ask me why but it surely has a meaningful explanation (e.g. oscillators, etc.). Aditionally the VST Bridge also produces some usage.
So that’s normal!!!
The only way to get rid of this standby CPU/Asio usage is to: Freeze the track (and unload instrument) or delete a track.

You can retest that by adding a 100% empty project and adding track by track with e.g. VSTi’s every new instrument should indrease ASIO usage…

Now: If during productions the ASIO usage comes to a limit there are two ways to reduce that:

  1. freeze as much tracks as you can and unload it’s instruments and inserts
  2. bounce/export some instrument tracks, reimport the audio and delete the MIDI/Instrument track (Muting of the tracks does not reduce ASIO load)

Hope that helps


Cheers…

This is why I stopped using CB 64. Of course, it’s not a problem for me because all my projects are not that memory intensive. If they were, I could still use Jbridge and get more with CB 32. I guess in this case, advantage windows.

These #s are all at idle:

Cubase … 32 … 64

Project w/no vst’s … 2% … 4%

Project w/CB native vst’s (no 3rd party) . 2% … 5%

Project w/multiple 3rd party vst’s … 4% … 35%

The only 3rd party vst I’m using in the forementioned project is Addictive Drums. It wasn’t considered a 64 bit plug but worked in that environment. Being as it was not considered fully compatible, it was a bigger drain on asio consumption.
Cubase’s native vst’s were much less of a draw because of their compatibility, however, still a bigger drain in CB 64. (marginal)
My guess is, if you disabled the CB bit bridge, the comparison may even out. Then of course, you would have to use all 64 bit plugs. I’ve seen threads where users are doing just that with no problems. I don’t know about their consumption though.

Thanks for the feedback, very helpful indeed.

So I’m starting to think my issue may be specific to my setup. Even if I start Cubase and let it sit there, without even loading a project the CPU usage is around 10%, which eliminates VST usage.

Oh, I just tried turning off my audio interfaces, Lexicon ionix and Yamaha Firewire, and it more than halved the cpu usage. I’m going to install Cubase 64 on my Windows 7 setup, if it fixes the cpu usage then sadly I might be forced to leave the mac os :cry:

With my setup, CB launched and no project loaded, 0%. My guess is it’s probably mac’s version of switchable bit environments. With Windows, 32 and 64 bit environments are two discreet OS’s. Not sure if that’s how Snow Leopard runs but the way you described it, it’s one OS that is configured to boot up in one of two modes.
I’d do what you planned with W7 and compare. There seems to be a conflict of some sort with your mac 'puter and CB 64. Keep us posted.

Ok, just discovered something interesting.

I have a new installation of Windows 7 64 bit Home Premium on Bootcamp. I installed Cubase 5.0 64 bit and the 64 bit version of my audio interface, Lexicon Ionix u82s, fired up cubase without opening a project and CPU usage sat at 0%. Then I installed the Cubase 5.5.3 64 bit upgrade, started Cubase without a project and the CPU sat at 6%.

So my guess is it’s something introduced in the 5.5.3 upgrade, or possibly the newer version of eLicenser that gets installed. I’m going to keep persisting with Windows at the moment, once I get all of my products installed I want to give Cubase a push to see what it can do. I’ll post some notes about my findings…

Will be interested in your findings.

I spent a day installing Komplete, Ivory, Kore, Halion Symphony and a bunch of other VST’s and updates on Windows 7 64. And the only thing I could get working was Halion Symphony, making it impossible to compare against Cubase 32 bit on Mac.

The standalone version of Halion didn’t work to start with, I installed the sample content on a different partition. But uninstalling it and reinstalling it on C drive worked, but still not the VST in Cubase. All of my other samples were installed on a different partition so maybe they all had a similar issue? Anyway I’ve run out of time so I’m going to live with my CPU usage issue for now.

Next time I try and get Cubase 64 bit working I think I’ll just get Cubase 6 for Mac and be done with it.