Crash

Hi,
I am new to this forum and have been using Cubase for some time, but still learning and have an issue that I am hoping someone here may be able to help with.
I created a project in Cubase Artist 8.5 that contains 4 audio parts, groove agent and a midi part. I am now working on this project in Cubase Pro 10 and have started experiencing crashing. The piece plays fine until around bar 97 and then a buzz (zzzzt) in left channel and then silence as the project scrolls on. Closing the project and reopening it restores the sound - I do not need to fully exit and restart Cubase to get it back.
The crash does not occur consistently at the same bar (it can occur earlier or later in the project), nor does it consistently occur with any particular action or command.
Disabing the midi/vst track prevents the crash but creating new track and pasting in events from the disabled track yields a crash.
This problem appears to be limited to this one project.
I have the original version that does not seem to crash, but I don’t want to lose my work on this version if possible. Any ideas?
Thanks
Kevin

Hi and welcome,

It doesn’t sound like a crash to me. If there would be a crash, Cubase would show you a “Serious error” message and quit.

Try to increase your Audio Device Buffer Size, please.

Hi Martin,
Thank you for responding. I checked the buffer setting and it was on small and I increased it to middle, tested it and then to large and tested it again. The glitch occurred intermittently on both the middle and large settings. I should note that this project is similar to many others that I have and this issue seems to be restricted to this project and the buffer size, which is global doesn’t seem to be an issue with my other projects. I did make an additional observation - since bars 1-75 and 76-150 -are essentially two separate takes, I tried to focus on the better first take and looped my playback on bars 1-75 and instead of the glitch happening at bar 97, it happened around bar 23 on the second playback suggesting that time in playback may be an issue?. Thanks.
-Kevin

Hi,

Can you hear the glitch when you Export Audio Mixdown, at the result WAV file?

Is there anything specific at the place where does it glitch? Do you use any DEMO/Trial plug-in by any chance?

Could you try to test your system by LatencyMon? When you find the place where does it glitch, can you observe your system in the Task Manager… Anything interesting there?

Hi Martin,
The glitch doesn’t consistently occur in the same exact place all the time. It does happen at bar 97 fairly frequently, but does occur elsewhere with no particular pattern and not in response to any action. Note that this project was recorded on another computer in Artist 8.5 and I am seeing the glitch on a new PC in Cubase Pro 10. I am not using any Demo/Trial plugins (Though I have loaded Vertigo Strings without a license and need to remove it).
I did a “Render in Place” for the midi track and the audio was rendered only to Bar 97 - the “zzzt” can be heard on the wave file and then silence. I have run latencymon and pastedreport below and can send you captured images from task manager and the wav image if you have email:
Thanks again.
Kevin



\


CONCLUSION


Your system seems to have difficulty handling real-time audio and other tasks. You may experience drop outs, clicks or pops due to buffer underruns. One or more DPC routines that belong to a driver running in your system appear to be executing for too long. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.
LatencyMon has been analyzing your system for 0:01:27 (h:mm:ss) on all processors.

\


SYSTEM INFORMATION


Computer name: DESKTOP-0KLLF29
OS version: Windows 8 , 6.2, build: 9200 (x64)
Hardware: Inspiron 5570, Dell Inc., 0G69K0
CPU: GenuineIntel Intel® Core™ i7-7500U CPU @ 2.70GHz
Logical processors: 4
Processor groups: 1
RAM: 8090 MB total

\


CPU SPEED


Reported CPU speed: 2904.0 MHz
Measured CPU speed: 3280.0 MHz (approx.)

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.

\


MEASURED INTERRUPT TO USER PROCESS LATENCIES


The interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.

Highest measured interrupt to process latency (µs): 1062.70
Average measured interrupt to process latency (µs): 11.656994

Highest measured interrupt to DPC latency (µs): 1053.90
Average measured interrupt to DPC latency (µs): 2.882325

\


REPORTED ISRs


Interrupt service routines are routines installed by the OS and device drivers that execute in response to a hardware interrupt signal.

Highest ISR routine execution time (µs): 137.158402
Driver with highest ISR routine execution time: ACPI.sys - ACPI Driver for NT, Microsoft Corporation

Highest reported total ISR routine time (%): 0.014189
Driver with highest ISR total time: ACPI.sys - ACPI Driver for NT, Microsoft Corporation

Total time spent in ISRs (%) 0.021538

ISR count (execution time <250 µs): 5683
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0

\


REPORTED DPCs


DPC routines are part of the interrupt servicing dispatch mechanism and disable the possibility for a process to utilize the CPU while it is interrupted until the DPC has finished execution.

Highest DPC routine execution time (µs): 1078.767906
Driver with highest DPC routine execution time: ACPI.sys - ACPI Driver for NT, Microsoft Corporation

Highest reported total DPC routine time (%): 0.195258
Driver with highest DPC total execution time: rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.

Total time spent in DPCs (%) 0.502547

DPC count (execution time <250 µs): 326131
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 218
DPC count (execution time 1000-1999 µs): 2
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0

\


REPORTED HARD PAGEFAULTS


Hard pagefaults are events that get triggered by making use of virtual memory that is not resident in RAM but backed by a memory mapped file on disk. The process of resolving the hard pagefault requires reading in the memory from disk while the process is interrupted and blocked from execution.


Process with highest pagefault count: none

Total number of hard pagefaults 0
Hard pagefault count of hardest hit process: 0
Highest hard pagefault resolution time (µs): 0.0
Total time spent in hard pagefaults (%): 0.0
Number of processes hit: 0

\


PER CPU DATA


CPU 0 Interrupt cycle time (s): 3.408371
CPU 0 ISR highest execution time (µs): 137.158402
CPU 0 ISR total execution time (s): 0.074976
CPU 0 ISR count: 5682
CPU 0 DPC highest execution time (µs): 1078.767906
CPU 0 DPC total execution time (s): 1.393112
CPU 0 DPC count: 268079


CPU 1 Interrupt cycle time (s): 1.381478
CPU 1 ISR highest execution time (µs): 3.705579
CPU 1 ISR total execution time (s): 0.000004
CPU 1 ISR count: 1
CPU 1 DPC highest execution time (µs): 117.590220
CPU 1 DPC total execution time (s): 0.031966
CPU 1 DPC count: 4340


CPU 2 Interrupt cycle time (s): 2.622485
CPU 2 ISR highest execution time (µs): 0.0
CPU 2 ISR total execution time (s): 0.0
CPU 2 ISR count: 0
CPU 2 DPC highest execution time (µs): 193.061983
CPU 2 DPC total execution time (s): 0.246320
CPU 2 DPC count: 42320


CPU 3 Interrupt cycle time (s): 2.414707
CPU 3 ISR highest execution time (µs): 0.0
CPU 3 ISR total execution time (s): 0.0
CPU 3 ISR count: 0
CPU 3 DPC highest execution time (µs): 96.699725
CPU 3 DPC total execution time (s): 0.078088
CPU 3 DPC count: 11612

Hi,

Now I think it’s not a Buffer Size problem. But anyway I would recommend to do what the LatencyMon application suggested.

Could you try to open the project and use File > Back up project function? Is the same problem in the newly created CPR file, please?

Hi Martin,
I did update the bios and drivers on my computer and I changed the power settings to limit throttling (best performance setting). I also have Iolo System Mechanic on my computer and have that set to Ultra Performance Music/Video production.

I also performed the project backup but the glitch persists.
Thanks again.
-Kevin

Hi Martin,
I did update the bios and drivers on my computer and I changed the power settings to limit throttling (best performance setting). I also have Iolo System Mechanic on my computer and have that set to Ultra Performance Music/Video production.

I also performed the project backup but the glitch persists.
Thanks again.
-Kevin

Hi Martin
another observation… I previously saw the glitch at bar 97 when played through… I also saw it when I had cycle playback on with the marker set at bar 75 and on the second cycle it glitched at bar 22 (75+22) - Tonight I let it play from zero and while in play at bar 33 I pressed the go to zero button |< and when it progressed to bar 33, I pressed the go to zero again and on the third cycle, it glitched on bar 31 (33+33+31).
-Kevin

Hi,

I’m sorry, I still can’t see any key.

Could you share the project via Dropbox, please?

OK Do you have an email address to send the link to?

Hi,

Could you upload it to Dropbox (or similar service) and send me a link via PM here, please?

Here you go Martin.
Thanks again.
-Kevin

https://spaces.hightail.com/receive/pAlzEBSgFH

Hi,

Thank you for the project. I can reproduce it. The LeftManual Organ (HALion Sonic SE) seems to be the problem here.

I would recommend to add a new Instrument Rack, new MIDI track and copy the MIDI data and the automation over to the new tracks (or an Instrument track…).

I reported this to Steinberg CAN-23929 with the slimmed down project attached.

Thank you Martin - could you tell me how one copies the automation? I have tried that with copy paste and did not have much success.

Hi,

  • Right click to the automation track and click to **Select All Events.
  • Ctrl/Cmd + C to Copy.
  • L to Locate Selection Start
  • Select new automation track.
  • Ctrl/Cmd + V to Paste.**

Hi Martin,
I tried your recommendation above - added new Halion Rack - added midi track and copied midi events in (I did not need to copy automation because there was none associated in the original). I then disabled all copies of the original midi track and played back with the new Halion Lower Manual Organ and got the same glitch.

I then disabled the new halion Lower Manual track and there was no glitch

I re-enabled the new Halion Lower Manual track and the glitch came back

I then switched the new Halion Instrument from Lower Manual Organ to Shiny Trombone and no glitch, so it seems to also be associated with that Organ /Track
-Kevin

Hi,

It’s reported to Steinberg and it really seems to be in HALion Sonic SE. Lets hope it will be fixed with the next update (probably of HALion).

Thanks Martin. I appreciate all your time with this.
-Kevin