Crashes, licences check bugs => tired of this

Hello all,

I’m gettting really tired about the crashes, freeze and licence check bugs i am experiencing with Cubase Pro 12. I have literraly 0 cracked plugins, i paid for each and every single software & plugins.
I understand companies need to control usage of the licenses they sell, but when it’s bothering 100% more the legit and paid customers more than frausters, I’d say there is a problem.

Countless times this year, i found myself tapping in google & on this forum ‘LCC2 error elicenser’ or ‘license check for content could not be completed’ each time it’s the same: restart in safe mode without any 3rd party, uninstalle elicenser and re-install… Right now, it’s already been 1 hours and half that i’m opening, force quitting, reopening my cubase session, and it still not work.

It reallty kills my enthuasiasm of making music and i lose precious hours, instead of spending time with my family or effectively making music.

I invested close to 700 or more pounds in steinberg product (wavelab, cubase, spectralayers) and i found myself not willing to move away, not because 'm very happy with the products but because of my investment. But when i try reaper, i’m like wouha, the license check is wayyyyy lighter and it’s soooooo fast, AND i can open several projects at the same time in tabs, really?

I am happy with my steinberg products, when they work.



2 Likes

Hi,

I don’t see any Soft-eLicenser Number in the eLCC. Please, use the eLCC Helper to generate one.

Hey Martin,
Thxs for jumping on this.

Is this what you are refering to, as a soft-eLicenser, in this screenshot?

Hi,

OK, now I can see the Soft- and USB-eLicenser Numbers. Please blur them on the screenshots.

So this is not the case.

Make sure, no firewall or antivirus is blocking the communication with the server, please.

ok just changed the screenshot to remove the number.
I’m on Mac, so I don’t have any antivirus or firewall.

Hi,

There is firewall on Mac too.

Also your internet provider might use one.

And the router connecting you to the Internet might have it also.

1 Like

Hello all,
Still having an issue.

I really am not sure what to do & how to solve it.
And again, I struggle to understand how such a sophisticated license system, like the one Steinberg has (dongle, e-licenser) is causing issues with 100% legitimate customer who paid each & every single of their software & plugins.

Any idea how to solve this, this is driving me crazy and really hinder me of using Steinberg product & do what I have to do.

1 Like

I’m not a Mac user but from the screenshot I can see that you are launching Cubase 12 in Rosetta mode. I guess this is due to some plugins that are not Apple Silicon native and require the eLicenser.

The error message basically says that the eLicenser Control Center can not connect to your licensing device. Do you have a USB eLicenser or do you use the Soft eLicenser?

In case of the USB eLicenser I would try a different USB port (no idea how many are available in your Mac). I assume you have the latest release of the eLicenser Control Center installed, in case not you can get it from here

Hi,

If I’m not mistaken, you can transfer most of the eLCC licenses to the new licensing system, now.

I believe, you run Cubase in Rosetta 2 because of the UAD, right?

Thanks.
I believe I use both the elicenser & the USB dongle across my different steinberg products.
I have this on the new licensing system already:

And this on the USB & Soft Licenser:

Happy to migrate everything that is possible on the new system to really abandon eLicenser system. I think I migrated everything I could, right?

Funny enough, I cannot log in to my Steinberg account anymore, tried to change the password twice, doesn’t work. Maybe this is also causing issues with eLicenser. My email didn’t change so not sure why the account email is not recognized…

Actually nothing in the e-licensing is important for me to keep.
How can i completely remove the e-licensing check from my laptop / cubase opening setting?

Hi,

Do you mean the USB-eLicenser or the Soft-eLicenser. If you mean the USB-eLicenser, you can just unplug it.

Btw, please blur the Soft-eLicenser Number and the USB-eLicenser Number at your screenshot.

ok let’s unplug then! and see if i still have these licensing issues.
Just blurred them, yes sorry.

1 Like

Wish you luck, but I am afraid that the problem is in the new steinberg licensing system. I have very similar issues with since I upgraded to Cubase 12, and I am going to downgrade on 11 to see if it’s better.

1 Like

I uninstall completely e-licenser, can someone tell me why i still have this pop-up:


What else do I need to do to get rid of the e-licenser?
@Martin.Jirsak ?

Hi,

I would recommend you to update Cubase to the latest version 12.0.52.

Please, make sure all other components are up to date. It might be, some old component’s licenses are still sitting on the eLCC.

And Steinberg Hub is still touching eLCC too. Why did you have a need to uninstall eLCC, please?