Creating Chord Events from MIDI problem

Hi folks,

I’m trying to create chord events from a midi track. Neither of what the manual states works (Creating Chord Events from MIDI):

Do one of the following:

  • Drag the MIDI part and drop it on the chord track.
  • Right-click a MIDI part, and select Create Chord Events from the context menu.
  • Select Project > Chord Track > Create Chord Events.

A dialog pops up, but after pressing “OK” no chord event is created.
The dialog is configured as follows:

Include Bass Notes
[] Include Tensions
] Detect Arpeggios
[_] Interpret Sustain Pedal
Ignore Notes Shorter Than

What am I doing wrong?

Any help is really appreciated.

Kind regards,

1 Like

To answer your question, it would be useful to know what notes are in the midi part you are dragging. Best to try a part for testing that has only one chord.

Hi, I can reproduce this… It used to work but it seems it doesn’t anymore. Even with a simple chord like a C major (no matter how long it is), if I drag and drop a midi event or the right click method, nothing happens.

I’m on win10, latest cubase 12 version

The only exception when it works is if the midi event came from the chord track or chord pad in the first place…
It also works fine if I render to audio and drag the audio instead…

I can’t reproduce this, and I think there are no reports of this outside of this topic. which leads one to suspect some kind of local problem,

Have you already ruled out prefs problems in Safe Mode?

Maybe post a cpr that shows the problem so others can check into it.

Ah I totally forgot about this one.

It actually depends on the settings you choose for create chords from MIDI. In my case it “works” when you activate “Detect Arpeggios”. But IMHO the detection is not really good compared to what GuitarPro offers. The detection often produces odd, off-beat chord events which is really not satisfying.

In my current workflow I export the notes as MIDI and let GuitarPro do the scale detection. Sad, but that produces better results.

In order for Cubase to detect a Chord it needs to identify 3 or more Notes that are in the Chord. If they are all playing at once, like with block chords, that’s easy enough. But if the Notes are not all playing simultaneously then it won’t be detected as a Chord unless the “Detect Arpeggios” option is selected. When this is selected, chord detection is based on which Notes are playing simultaneously plus potentially any adjacent Notes.

The problem with single Notes in this context is that their role is intrinsically ambiguous. It could be a Note in the preceding Chord, the following Chord, both, or even a passing tone that belongs to neither. Depending on what you assume the Note’s role is, you might end up with different Chord Names. Personally when I don’t agree with the automated identification it’s easy enough to manually change it.

Just tried in safe mode. Running into the same exact issue.

This is 12.0.60 on windows 10. Everything is up to date.

I do have cubase 11 installed on the system as well.

This is the easiest possible chord for it to detect, a major C in a solid 2 measure block… Tried all settings, and it does not work in any scenario, either from midi or instruments tracks.

Notice how doing the same thing from the rendered audio track works fine

Starting with infinite OBS is pretty scary.

Yeah, that is pretty weird. Can you post a screenshot that shows the Chord Track’s Inspector. Does it work in 11?

How do you know it’s a C major chord? It could just as well be C minor, or the 3 and 7 of an Am7 or AbMaj7 etc…

The point is, as has been discussed in this topic, that your chord has no 3rd, and the algo needs to find a root, 3rd and 5th before it can define a chord, just like humans. :robot:

Good catch.

1 Like

Christ… you’re right, this is what happens when I try to troubleshoot something after a full day of QA at work hahahaha. I feel stupid, this is a ‘‘powerchord’’ and not a C major per se.

But … I’ve tried to do this with a bunch of different chords in a bunch of different projects… same results every time UNLESS the midi event has a chord already tagged on it (dragged from chord pad or chord track event)

In cubase 11, it sort of works but it’s super finicky. I’ll drag a midi event that covers an entire song and it’ll catch one chord only, for example.

What I find really weird is that it works fine with audio.

Thanks for the prompts responses folks, I appreciate it! Happy Friday :slight_smile:

Sorry, but if you want to report a bug it has to be in a way that others can reproduce. What you’ve provided is not specific enough to help troubleshoot or find a bug.

The feature does work though.

This is not a Cubase thing.

I’ll try again over the weekend with a proper C major … hopefully it was user error on my end.

Thanks again

1 Like

Jumping in here a bit haphazardly…
In the video example above, why isn’t Cubase detecting it as a C5 or C(no3)?

Because it’s not a chord – it’s is more a common shorthand for perfect 5ths or 4ths. It doesn’t have a basis in chord theory, nor a function – it has no meaningful inversions either.

@steve I’m well aware of those arguments, but still, it being used in written music. It is not as clear cut as you might want to think. Music theory and notation is an evolving science.

I know you are. But the fact of something being used or not doesn’t affect the theory behind it.

That’s not to say a feature couldn’t be added for such an exception, but it would be an outlier, and would not need chord track analysis or voicing functions.


I wanted to add as well, this could be conceived as a customization in the Customized Chord preferences pane, but even that would be an “island” concept – a lone structure unrelated to the rest of the chord system.

In my view, the problem is the general limitation in the way the system operates. There are other chord spellings which are also not available. So I hope you understand where I’m coming from with my comments about this.

I would like to be able to create any possible, even idiosyncratic, chord spellings using the Chord Track, but this is only possible in the Score Editor’s manual chord symbol display feature (the old, original one).

Agreed. I think I talked about this as well in another thread… I don’t remember when.
I think no 3 chords were discussed there. I don’t think you can enter no 3 chords on the Chord Track, right? (11no3 might be the more common one.)

Cubase does not understand unless there’s a 3rd, pointe finale.

Well Steve, that’s the issue, right there, isn’t it? Cubase’s understanding of chords is limited.
(Besides, it’s not completely true since Cubase’s chord track does allow Sus chords.)