Creating Sample Plugins on Mac

I am using:

MacOS: 11.2.3
Xcode: 11.6
CMake: 3.20.1
VST3: 3.7.x (not sure of exact, got this from the readme)

When try to build example projects in Cmake gui or I run
/Applications/CMake.app/Contents/bin/cmake -G Xcode …

I get :

CMake Error at cmake/modules/SMTG_DetectPlatform.cmake:27 (message):
XCode 9 or newer is required
Call Stack (most recent call first):
cmake/modules/SMTG_Global.cmake:23 (smtg_detect_xcode_version)
cmake/modules/SMTG_VST3_SDK.cmake:5 (include)
CMakeLists.txt:19 (include)
– Configuring incomplete, errors occurred!

I have looked for answers on how to fix this to no avail.

Any help is greatly appreciated!

Please check if in Xcode and its settings under the Locations tab you have something selected in the “Command Line Tools:”

That was it!

Thanks!!!