Crossfade settings reset when clips are moved

I hope this isn’t normal behaviour or that it can be overridden:

When in a montage with two clips overlapping on the same track, I can adjust the fade-out and fade-in handles to taste. Great! HOWEVER, as soon as I move one of the clips, the fades are reset to the exact length of the overlapped area. This is super-annoying!

Look at the setting in the Fade Ribbon Tab in the “Clip Options” section called “Automatic Changes”. If you read the Tell Me More section you may decide to turn this option off. (see screen shot).

Another option is to use two montage tracks and have the clips on their own track. Sometimes that is less messy overall.
Screen Shot 2016-11-15 at 7.36.27 AM.png

Thanks Justin P for taking the time to reply with a nice screen shot. That did the trick! Although I think anything automatic which overrides manual settings should be off by default…