Ctrl+S gives long saving/waiting time...

Hello, I have little problem with Cubase 8 Pro but frequent. I often save my project progres by hitting Ctrl+S, but every time when I hit these keys it causes long time of waiting during which I can’t work further, so I have to wait just a couple of seconds I mean 6 or even ten. I know this isn’t too much but I save my project progres many times during work so it results a couple of wasted minutes and sooner heart attack :slight_smile:

What can cause this waiting time? And how can I mend this problem, or maybe there is an autosave option or another way to saving? THANKS !

p.s. i7, 32GB RAM, internal SSD 100GB of free space, Win 10

I’ve seen this issue arise when there are certain VSTi’s loaded, or if there is a large amount of data in the Pool. What do you have going on in the session?

I usually set over 30 VST instruments (mainly Kontakt 5) into one project. Anyway I have made a test: I put near 40 audio tracks (with samples and recorded audio and inserted effects etc.) and when I hit Ctrl+S it was just 1 second to wait, but when I put some vst instruments, even just HAlion etc.
it has started to lagging to over 5-10 seconds.