Cubase 10.0.20/30 crashes on project load


Cubase 10.0.20 and 10.0.30 is crashing every time I open one of my recent projects (created with 10.0.20). The exact same project file consistently opens with Cubase 8.0.40 and after I save it in Cubase 8, I can open it at least once with 10, but then it will happen again.
I suspected my relatively old Waves plugins, so I removed them all, but the problem persists. Another way to open the project with C10, is to open an empty template and then open the crashing project and activate it.

I’m running MacOS 10.14.6 (latest) on a late 2013 MacBook Pro quad core with 16GB RAM. My interface is a UA Apollo Twin and my UAD software is up-to-date. Tried to load the project with my Apollo turned off, so that the plugins will be disabled - still crashes.
The crashing project is very minimal and contains one audio track, one Kontakt VSTi track and one padshop track. It uses few UAD plugins that I use in most of my projects and so far all other projects I tried seem to open properly.

Can anyone from Steinberg help me figuring out what causes these crashes?

Crash dump file attached.

Cubase 10_2019-07-28-075533_Shais-MacBook-Pro.crash (129 KB)