Cubase 10.5.12 Enable Solo on Selected Track not working

Well, the title says it all.

Preferences > Editing > Project & MixConsole
Enable Solo on Selected Track

Not working. :frowning:

Same here Bro, no work

Enquiring minds want to know:

  1. Mac or PC?
  2. What OS?

Same here too. Very annoying as I need this option reaaly bad.

I understand how it works now, you need to first solo a track and then selecting another one will solo the new track and so on.