Cubase 10.5.20 Maintenance Update

:::waiting for Mac users to check in:::

Little help here… Anyone?
Ok I’ll assume that it’s still broken and not waste my time updating.

Thanks.

Does a Hackintosh count as a Mac?

Cubase 10.5.20 works OK, just as 10.5.12 did. On my system. Not perfect, but quite usable.
Some combinations of plug ins give me grief, hitpoint detection is not reliable, but I can get work done without showstoppers.

+1

Partial workaround for Windows 10 users: Print -> “Microsoft Print to PDF” the online release notes.

Anyway: please add a “Download pdf” button to the online release notes page.

Yes, it’s quite serious. I have lost projects because of this. After finishing projects I use to archive them using this feature. Worst thing is that I only found out about this bug several months later when I already had deleted the original folders. So I can’t open them.

Same issue here. Sorry for asking here, but how would I revert back to .12?? I updated with the small 600MB download and I tried installing the .12-Update from before, without success. Would I have to download the full install?

Any word on ucrtbase.dll crashes? Because Cubase is totally unusable for me at the moment. Crashes every time i use it without fail.

Control panel > Programs > Programs and Features . installed updates

Here you can see what you have installed and roll back to the previous version of Cubase.

Well that is if you are on Windows!!

Just updated from 10.5.12 to XXX.20. I’ve just used it for 30 minutes and all is ok. I installed the new Win10 2004 just prior to CBase update. Use DMG and SSD5 along with Steinberg.

Thank you very much! This “play-head jumping back after pressing stop” made me go bonkers! (Yes, it is disabled in the preferences).

My Hackintosh is more Stable than my Macbook Pro and any Mac I’ve owned previously. Runs Cubase 10 24/7 without a glitch. 10.5, however, is another kettle of fish.

Hi Matthias, there´s a couple of us with a showstopping issue in .20, the playback cursor always reverting back to the same random point in the project. Return to start position preference doesn´t affect it.

All was well until i tried to install 10.5.2…now I’m;

…unable to get a clean install of 10.5.20, using late-2012 i7 MBP & Catalina 10.15.5…
…program Initializing: be comes unresponsive while scanning vst3 plugins…
…am unable to load 10.0.6, 10.5.0 as well…same scenario…
…properly installs if i choose to load only Steinberg plugins…

I am back to 9.5!
any suggestions are welcomed…

BTW - UAD LUNA WORKS JUST FINE!!

Steinberg want to sell you the same thing twice or three times. Chase 10 with 4k support, Cubase 10.5 with 4k support and next it will be Chase 11 with 4k support and lots of new bugs. for lots of money. Everybody should write to their local trading standards office and complain rather than write to steinberg, they’re not bothered.

Also: The HiDPI issue is soooooooooooooooooooooooooooooooooo disappointing. I neglected to mention it before, because (frankly) I’ve gotten so resigned to it -not- working. Which sucks. The fact that I just assume they -can’t- fix it, is a drag.

anyone has 10.5.19 available for d/l? also, is the release notes for that availalbe online?

I always, always, always (every week normally) make a systemcopy (W7 backup function in W10) of my C-drive before installing Cubase or Windows updates. Takes about 20minutes If you have a SSD and just as long to put a sytemcopy back on the C drive, without problems.
Test everything after installing and can go back to my previous C-drive that was working just fine.

The company deals with its customers in a very strange way
Why don’t you just look at us? And you hear our voices

This is the solution. I saw one of the brothers design this picture, but there was no response from you


:exclamation: :exclamation: :exclamation: :exclamation:

Your text is scaling perfectly

Trick in mediabay that I used for years from which my workflow deeply depends on it suddenly gets broken in this .20 update :frowning:
Here is what i mean: https://www.steinberg.net/forums/viewtopic.php?f=250&t=128461