Cubase 10.5.20 Maintenance Update

Steinberg want to sell you the same thing twice or three times. Chase 10 with 4k support, Cubase 10.5 with 4k support and next it will be Chase 11 with 4k support and lots of new bugs. for lots of money. Everybody should write to their local trading standards office and complain rather than write to steinberg, they’re not bothered.

Also: The HiDPI issue is soooooooooooooooooooooooooooooooooo disappointing. I neglected to mention it before, because (frankly) I’ve gotten so resigned to it -not- working. Which sucks. The fact that I just assume they -can’t- fix it, is a drag.

anyone has 10.5.19 available for d/l? also, is the release notes for that availalbe online?

I always, always, always (every week normally) make a systemcopy (W7 backup function in W10) of my C-drive before installing Cubase or Windows updates. Takes about 20minutes If you have a SSD and just as long to put a sytemcopy back on the C drive, without problems.
Test everything after installing and can go back to my previous C-drive that was working just fine.

The company deals with its customers in a very strange way
Why don’t you just look at us? And you hear our voices

This is the solution. I saw one of the brothers design this picture, but there was no response from you


:exclamation: :exclamation: :exclamation: :exclamation:

Your text is scaling perfectly

Trick in mediabay that I used for years from which my workflow deeply depends on it suddenly gets broken in this .20 update :frowning:
Here is what i mean: https://www.steinberg.net/forums/viewtopic.php?f=250&t=128461

Matthias Quellmann,
Please read my above post, and suggest a possible resolution or provide a link for an earlier known good dmg…

All seems the same as 10.5.12 for me. Used for the last 2 days and only had 1 spinning ball Force quit, caused by a UAD plugin.
The contrast for dark mode text fix has worked bar 1 plugin, but on the main menus all seems good.
Loving the selected mixer channel with a bright colour setting.
Have put cut head and tail on Metagrid buttons and enjoying when working on vocals.
Plugin report is cool, found out I had 2060 installed!
The new startup Page when crashed Is a worthwhile addition.
The colour scheme looked slightly different and am happy with my adjustments.
Still seems that the average load meter goes up on soloing a channel…
Generally quite happy with these improvements.

Intuitively I am thinking that the increase in cpu between 10 and 10.5 may well have something to do with the new eq channel and spectrum display.
I use this a lot now as very easy with my controllers and happy with the colour scheme I changed to. Just wondering if cost is more cpu as something like Harrison legacy q has a big increase whilst using the analyser, which Harrison advises you to turn off, when not needed…

I think it would be useful to be able to download earlier versions of updates for cubase 10 from ftp://ftp.steinberg.net/

I fail to understand why thats not an option. no other company does that.

Please fix Cubase hangs on quit when using heavily buffered plugins like Acustica Audio Nebula and Acqua. All other DAWs manage it easily.

I couldn´t agree more but I have the feeling its Yamaha that´s not bothered because if they were they would have ordered someone to sort it by now. Unless of course it is impossible to do so in which case they should be honest enough to say so.

I totally agree with you
I am shocked by all this ignorance
I have previous experience in programming, solving the issue does not require much time

And if you got errors with them during programming
Microsoft has programmed Windows 10 from scratch
It is an integrated computer system, not a program

The solution should be completed as soon as possible, even if it is temporary, because this is a basic requirement and not an Extra Feature

I just updated from 10.5.0 to 10.5.20 and seems to be working ok so far on Macbook Pro running OS 10.14.6. That was not my experience with 10.5.12. I’ll report if there are any issues I come up with.

No hiDPI for Windows versions yet I see.
Over 20 years of dedication to your company and I am realizing maybe further dedication to you may be a mistake.
It’s time to take a serious look at Studio One.

Hi,

Could you try in Cubase Safe Start Mode [Disable preferences], please? Just to confirm or disprove it’s a preferences issue.

Hi,

Are you on Mac or Windows, please?

Hi,

Cubase 10.0 and Cubase 10.5 are independent applications, they event don’t share the preferences. So it’s hard to imagine Cubase 10.5 installation would affect Cubase 10.0.

What eLCC version do you use, please?

Hi,

This is broken since Cubase 10.5.0. It’s known and already many times reported issue. Thank you.

Does this bug exist in 10.5 ? https://steinberg.net/forums/viewtopic.php?f=286&t=190347
Its very important fix for my work