Cubase 10.5.20 Maintenance Update

Matthias Quellmann,
Please read my above post, and suggest a possible resolution or provide a link for an earlier known good dmg…

All seems the same as 10.5.12 for me. Used for the last 2 days and only had 1 spinning ball Force quit, caused by a UAD plugin.
The contrast for dark mode text fix has worked bar 1 plugin, but on the main menus all seems good.
Loving the selected mixer channel with a bright colour setting.
Have put cut head and tail on Metagrid buttons and enjoying when working on vocals.
Plugin report is cool, found out I had 2060 installed!
The new startup Page when crashed Is a worthwhile addition.
The colour scheme looked slightly different and am happy with my adjustments.
Still seems that the average load meter goes up on soloing a channel…
Generally quite happy with these improvements.

Intuitively I am thinking that the increase in cpu between 10 and 10.5 may well have something to do with the new eq channel and spectrum display.
I use this a lot now as very easy with my controllers and happy with the colour scheme I changed to. Just wondering if cost is more cpu as something like Harrison legacy q has a big increase whilst using the analyser, which Harrison advises you to turn off, when not needed…

I think it would be useful to be able to download earlier versions of updates for cubase 10 from ftp://ftp.steinberg.net/

I fail to understand why thats not an option. no other company does that.

Please fix Cubase hangs on quit when using heavily buffered plugins like Acustica Audio Nebula and Acqua. All other DAWs manage it easily.

I couldn´t agree more but I have the feeling its Yamaha that´s not bothered because if they were they would have ordered someone to sort it by now. Unless of course it is impossible to do so in which case they should be honest enough to say so.

I totally agree with you
I am shocked by all this ignorance
I have previous experience in programming, solving the issue does not require much time

And if you got errors with them during programming
Microsoft has programmed Windows 10 from scratch
It is an integrated computer system, not a program

The solution should be completed as soon as possible, even if it is temporary, because this is a basic requirement and not an Extra Feature

I just updated from 10.5.0 to 10.5.20 and seems to be working ok so far on Macbook Pro running OS 10.14.6. That was not my experience with 10.5.12. I’ll report if there are any issues I come up with.

No hiDPI for Windows versions yet I see.
Over 20 years of dedication to your company and I am realizing maybe further dedication to you may be a mistake.
It’s time to take a serious look at Studio One.

Hi,

Could you try in Cubase Safe Start Mode [Disable preferences], please? Just to confirm or disprove it’s a preferences issue.

Hi,

Are you on Mac or Windows, please?

Hi,

Cubase 10.0 and Cubase 10.5 are independent applications, they event don’t share the preferences. So it’s hard to imagine Cubase 10.5 installation would affect Cubase 10.0.

What eLCC version do you use, please?

Hi,

This is broken since Cubase 10.5.0. It’s known and already many times reported issue. Thank you.

Does this bug exist in 10.5 ? https://steinberg.net/forums/viewtopic.php?f=286&t=190347
Its very important fix for my work

Hi there,

Our QA is on it and will check if they can reproduce the issue.

Thanks for the report,
Matthias

Hi,

This change was intentional to improve the consistency of these type drop down selections. I will talk to the team about your feedback.

Thanks,
Matthias

We are still working on it. It’s not a quick win and the scaling needs a lot of testing and refinement though. Unfortunately there won’t be any improvement before Cubase 11.

It seems like a hick-up in the prefs. Have you tried to delete your preferences?

I’m not believing what I am reading right now. :neutral_face: Anyone ever heard the saying “IF IT ISN’T BROKEN DON’T FIX IT”?

Huh! But we’ve already bought it as it was advertised 18 months ago! Does that mean that cubase 11 will be a free upgrade for people who’ve already bought Cubase 10 HiDPI when it was releasd? And what about eucon? 4-1/2 years down the line and still no update!

Please bring this functionality back as an option. I use it numerous times during each session, so much so that I rolled back to the previous version.