Cubase 10.5.20 random note offs (!?)

Hello everyone,
I am fighting with something that is apparently a bug, but I can’t pin it down to what’s really going on.
When playing midi regios, sometimes some (or all) notes get randomly shut off. I attached a short video of a rough sketch. First playthrough the high strings get cut off in the middle of the note, I play it again and everything is fine. Sometimes this happens very often, sometimes only once in a while. Often enough that it stops me from being able to work with 10.5. It happens in random places, not all the time in the same place and with different tracks, sometimes all of them at the same time.
When confirming with the GUI of the instrument, it’s not only the sound that’s cut off, but the key in the GUI actually gets released. It is as if the instrument would receive a note off command.

I don’t know if this has anything to do with the expression maps bug (Cubase 10.5 changes exp. maps articulations on playback. [Fixed in C11/10.5.30] - Cubase - Steinberg Forums). I had problems with that bug as well. I was trying 10.5 again these days and the expression maps bug occurs much less now (subjectively speeking). But these dropped notes are a real pain.
I work with Spitfire BBCSO Pro, but the same thing also happens with other instruments like SWAM Strings.

I spent several hours trying to narrow it down, but I didn’t come to a conclusion. Anyone has any idea what’s happening here?

Thanks a lot. And sorry for the shitty video quality.

P.S. Specs:
Win 10 Pro, 32GB, 9900k.
Cubase 10.5.20 Pro
Metagrid, nanoKontrol 2, TEC Breath&Bite, Maschine Mikro (in MIDI mode), Divisimate


Try to increase or decrease the Audio Device Buffer Size.

You can also try to set all MIDI Inputs to Not Connected, or make sure, there is no Record Enable or not Monitor enabled on the tracks (just to make sure, none of MIDI device doesn’t send the Reset message).

Hi Martin, thank you.

Unfortunately this doesn’t make any difference. It happens even with all MIDI inputs disconnected. Also happens on different devices (beefy desktop with 9900k as well as my laptop). Happens with Focusrite 18i20 drivers as well as Generic Low Latency drivers.

Yeah, this happens to me as well with HZ Strings. What I realized was that the Spitfire sampler was taking very long to load the damn samples.

So what I did was load the project, give it about 5 to 10 minutes for the sampler to load everything, and then do a playback. The dropped notes then stopped happening.

Hmmm thought of this. But it doesn’t only happen with Spitfire stuff, also with Audio Modeling. And even after a good amount of time working on a project. It also happens on my machine with 64GB of RAM, it should be able to load my template almost entirely into RAM. But maybe it has to do with BBCSO indeed… Have to try to setup a big session without Spitfire’s player involved. Is it even possible, that the Spitfire Player wrestles with the system in a way that effects other VIs as well?

Man, now this I’m not really sure. Just curious, are you loading alot of instruments? Roughly how many tracks? I’m not sure if 64 is enough.
Also, how many spins is your hard drive? Is it a workhorse or the eco-friendly type?

it depends. My desktop has only 32 GB (which isn’t perfect), but everything is streaming from a SSD via USB 3.1. My Laptop has 64GB and streaming from a NVMe SSD, but it obviously isn’t quite as powerful as my desktop rig cpu wise (9750H vs 9900k).
Anyways I doubt that it is a problem with my particular machines, because it doesn’t happen at all in 10.0
Then again others apparently don’t have that problem, so maybe I am able to solve it over here too.
Secretely I hope that Steinberg will just have it fixed in 11.
It occurs when I put considerable strain on the system, but nothing insane.
Maybe like 20-30 instances of Spitfire BBCSO + around 15 instances of Audio Modeling SWAM stuff. Other than that maybe another 5-10 instances of random stuff, Retrologue, maybe Kontakt with a piano, stuff like that. A couple of Valhalla Room instances and some soundtoys, that’s it.

Welp, ya got me! I have no idea then. Note dropoffs are no excuse for an SSD drive.

All this tells me is that somehow, the nature of how DAWs and VSTis work, is mysterious beyond just great computer specs.

Hope this irritating thing of yours gets resolved somehow. Good luck my friend.

From my experience this is often VSTi related.
Cubase won’t send note-off messages - instead it sends note-on with Velocity = 0 and I think some instruments have a problem with that.
This option can help a little:

  • reset on stop
  • insert reset events after record

Gonna try this. Although it still is strange that it doesn’t happen in 10.0

Dug into it a bit more and the Reset features unfortunately don’t help me at this point. The problem I have isn’t with stuck notes, but with notes stopping out of the blue… I just hope that this got fixed again in 11.0 and everything just works again :smiley:

Exactly same thing happening here, it was all working fine with C10.
It doesn’t happen too often, but often enough to get me out of the zone… :unamused:
Cubase 10.5 introduced some important issues around MIDI.
I also have the feeling this might be related to the random expression maps issue as well.

I just tried C11 and so far everything is working fine. My thoughts: Could it be that old preferences were messing things up? When I moved to C10.5 I just moved the preferences folder to 10.5. I fear this could have introduced the problems.
C11 is still in factory state, I just loaded my template, no messing with generic remotes, metagrid, key commands and other settings so far. I really hope this is it… Maybe someone with the same problem wants to double check…