Cubase 10.5 and Behringer x-touch

After upgrading to Cubase 10.5 pro I can’t see the Behringer x-touch in the studio setup but have no trouble in 10 pro
anyone who knows something

Hi and welcome,

Can you see it in the Studio Setup > MIDI Port Setup?

My X-Touch is behaving normally under 10.5.

yes I can see the midi ports it works know

Perhaps initially you launched Cubase and then powered up the X-Touch rather than the other way around?


Cubase should recognise newly connected MIDI Device when Cubase is running. If it doesn’t then its a bug.

But Cubase does not I’m afraid. I use the X-One, and also have to start it first before Cubase is running

The same happened to me. I just had to reinstall it via add midi device and it’s been OK since then.

Agreed I always have to turn on the X touch one be for cubase.

It works no problem in 10.5 for me (no different to 10 or 8).

But it doesn’t for X-Touch.

I always assumed that it was because of it using a Remote Device. Just did a little test and that seems to be the case.

I have a Steinberg CMC-AI and CMC-QC. I unplugged the AI before launching Cubase. In Remote Devices the CMC-AI device doesn’t even show up. Then if I plug the AI in it does not cause the AI device to show up in Remote Devices and of course it doesn’t work. Meanwhile the QC worked as expected throughout.

Next step

The X-Touch uses the Mackie device and if it is on when launching Cubase then the MIDI In & Out for the Mackie device will be the X-Touch and all works as expected. But if the X-Touch is off at launch then the Mackie In & Outs will show as “not connected.” Then if you turn the X-Touch on, the Mackie device will change its In & Out to X-Touch. Except the X-Touch still doesn’t work.

I’ve always relaunched Cubase when this happens

But… Good News

It turns out that in Remote Devices if you select the Mackie device and hit the Reset button near the bottom (not the reset link near the top) then the Mackie will spring to life!!!

I’ve used xtouch with cubase since the xtouch was launched , ive added expander to the xtouch and had no problems with that either untill now ( C10) . the xtouch is “dead” but the expander comes to life. ive updated firmware etc but no luck.


Hi and welcome,

Try to use the the main unit without the expander first, please. Once it’s working, try to add the expander, please. Make sure, you have two Mackie devices in Cubase > Studio > Studio Setup, please.